Skip to content

← Actionable
Medium, CVSS 6.8amended

Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv4-mapped IPv6 (Incomplete fix of CVE-2026-25580)

CVE-2026-46678GHSA-cqp8-fcvh-x7r3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pydantic-ai 1.99.0; pydantic-ai-slim 1.99.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-46678: 0.38% estimated exploitation activity in the next 30 days; percentile 32.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When an application using Pydantic AI opts a URL into forcedownload='allow-local' (which disables the default block on private/internal IPs), the cloud-metadata blocklist could be bypassed by encoding the metadata IP in an IPv6 transition form (IPv4-mapped IPv6, 6to4, or NAT64). Dual-stack and translated networks route the IPv6 wrapper to the underlying IPv4 endpoint, exposing cloud IAM short-term credentials. This is an incomplete fix of GHSA-2jrp-274c-jhv3 / CVE-2026-25580. The parent advisory's remediation guaranteed that "cloud metadata endpoints are always blocked, even with allow-local." That guarantee did not hold for IPv6-encoded forms of the metadata IPs. Severity Same impact metrics as the parent CVE, but materially narrower attack surface (AC:H instead of AC:L), because exploitation requires the application to have opted into allow-local on a URL influenced by untrusted input. Who Is Affected Applications are affected only if they explicitly opt for FileUrl…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cqp8-fcvh-x7r3

  2. Revision 1 · created ·

    Published from osv record GHSA-cqp8-fcvh-x7r3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46678

Advisory: Pydantic AI: SSRF cloud-metadata blocklist bypass via IPv4-mapped IPv6 (Incomplete fix of CVE-2026-25580)
IDs: CVE-2026-46678, GHSA-cqp8-fcvh-x7r3
Record: https://patchnext.com/advisories/cve-2026-46678 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pydantic-ai 1.99.0; pydantic-ai-slim 1.99.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pydantic-ai: affected >= 1.56.0, < 1.99.0; fixed in 1.99.0
- PyPI pydantic-ai-slim: affected >= 1.56.0, < 1.99.0; fixed in 1.99.0

## Suggested inspection (read-only)
- `python -m pip show pydantic-ai`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show pydantic-ai-slim`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pydantic-ai, pydantic-ai-slim.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cqp8-fcvh-x7r3 (OSV record GHSA-cqp8-fcvh-x7r3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =1.56.0 <1.99.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cqp8-fcvh-x7r3 (GitHub-reviewed advisory GHSA-cqp8-fcvh-x7r3 lists affected ranges: PyPI pydantic-ai >=1.56.0 =1.56.0 <1.99.0)

Commands are suggestions: review each one before running it.

Loading voting…