symfony/polyfill-intl-idn: xn-- labels with ASCII-only Punycode payloads are treated as equivalent to their decoded form
CVE-2026-46644GHSA-2xf4-cg6j-vhgq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/polyfill 1.38.1; symfony/polyfill-intl-idn 1.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/polyfill
- Affected
- >= 1.17.1, < 1.38.1
- Fixed in
- 1.38.1
Packagist symfony/polyfill-intl-idn
- Affected
- >= 1.17.1, < 1.38.1
- Fixed in
- 1.38.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2xf4-cg6j-vhgq lists affected ranges: Packagist symfony/polyfill >=1.17.1 =1.17.1 <1.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2026-46644: 0.54% estimated exploitation activity in the next 30 days; percentile 45.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description symfony/polyfill-intl-idn provides a userland implementation of idntoutf8() and idntoascii() for runtimes that lack the intl extension. Its Idn::process() method decodes labels prefixed with xn-- using Punycode but never enforces the validity criterion added in UTS #46 revision 33 Section 4 step 4.1.2: after a successful Punycode decode, the result must contain at least one non-ASCII code point. As a consequence, xn-- labels whose Punycode payload is empty (xn--) or decodes to a string made of only ASCII code points (e.g. xn--kc1zs4-) are accepted by the polyfill while PHP's native ext-intl rejects them with IDNAERRORINVALIDACELABEL. Originally unequal domain names are therefore regarded as equal, which can lead to blacklist bypassing, inconsistent URL parsing and server-side request forgery (similar to CVE-2024-12224). Example with IDNAUSESTD3RULES | IDNACHECKBIDI | IDNACHECKCONTEXTJ | IDNANONTRANSITIONALTOASCII: | Input | Polyfill output | Native ext-intl output | | ---…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2xf4-cg6j-vhgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46644 Advisory: symfony/polyfill-intl-idn: xn-- labels with ASCII-only Punycode payloads are treated as equivalent to their decoded form IDs: CVE-2026-46644, GHSA-2xf4-cg6j-vhgq Record: https://patchnext.com/advisories/cve-2026-46644 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/polyfill 1.38.1; symfony/polyfill-intl-idn 1.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/polyfill: affected >= 1.17.1, < 1.38.1; fixed in 1.38.1 - Packagist symfony/polyfill-intl-idn: affected >= 1.17.1, < 1.38.1; fixed in 1.38.1 ## Suggested inspection (read-only) - Packagist symfony/polyfill: check the installed version with your package manager. - Packagist symfony/polyfill-intl-idn: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/polyfill, symfony/polyfill-intl-idn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2xf4-cg6j-vhgq (GitHub-reviewed advisory GHSA-2xf4-cg6j-vhgq lists affected ranges: Packagist symfony/polyfill >=1.17.1 =1.17.1 <1.38.1) Commands are suggestions: review each one before running it.
Loading voting…