Skip to content

← Actionable
High, CVSS 8.7

Twig: Arbitrary PHP code execution via _self.( ) macro-reference compilation

CVE-2026-46640GHSA-45vw-wh46-2vx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist twig/twig

    Affected
    >= 3.15.0, < 3.26.0
    Fixed in
    3.26.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-46640: 0.64% estimated exploitation activity in the next 30 days; percentile 50.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The obj.(expr) dynamic-attribute syntax (added in 3.15.0 as the replacement for the deprecated attribute() function) lets the attribute be an arbitrary expression. When the receiver is self (or any {% import %} alias) and the parenthesised expression is a string literal, DotExpressionParser short-circuits to the macro-call path and concatenates the attacker-controlled string into a MacroReferenceExpression name with no identifier validation. MacroReferenceExpression::compile() then emits that name raw into the generated PHP source. An attacker who can supply template source can inject arbitrary PHP into the compiled template and execute it at template-load time, before checkSecurity() is ever called. This is a complete bypass of SandboxExtension, including a globally-enabled sandbox with an empty SecurityPolicy allowlist. Resolution The parser now validates that the dynamic attribute resolves to a valid macro identifier before routing through MacroReferenceExpression, and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-45vw-wh46-2vx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46640

Advisory: Twig: Arbitrary PHP code execution via `_self.( )` macro-reference compilation
IDs: CVE-2026-46640, GHSA-45vw-wh46-2vx8
Record: https://patchnext.com/advisories/cve-2026-46640 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist twig/twig: affected >= 3.15.0, < 3.26.0; fixed in 3.26.0

## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-45vw-wh46-2vx8 (GitHub-reviewed advisory GHSA-45vw-wh46-2vx8 lists affected ranges: Packagist twig/twig >=3.15.0 <3.26.0)

Commands are suggestions: review each one before running it.

Loading voting…