Twig: template_from_string() escapes a SourcePolicy-driven sandbox via synthesized template name
CVE-2026-46634GHSA-24x9-r6q4-q93w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist twig/twig
- Affected
- >= 3.9.0, < 3.26.0
- Fixed in
- 3.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-24x9-r6q4-q93w lists affected ranges: Packagist twig/twig >=3.9.0 <3.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2026-46634: 0.62% estimated exploitation activity in the next 30 days; percentile 49.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When the sandbox is enabled selectively via SourcePolicyInterface (and not globally), a sandboxed template that is allowed to call templatefromstring and include can render an arbitrary inner template with no security policy enforcement. Environment::createTemplate() compiles the inner string under a synthesized name (stringtemplate<hash), so a name/path-based SourcePolicy returns false for it, and the inner template's checkSecurity() becomes a no-op. From a template the integrator believes is sandboxed, an attacker can use any tag/filter/function (including constant() to read secrets, or |map("system") to execute shell commands). Resolution This is a configuration trap rather than a code bug: there is no legitimate use case for exposing templatefromstring to untrusted template authors, and propagating the parent sandbox state through templatefromstring would require invasive changes to SourcePolicyInterface semantics with their own risks. Starting with Twig 3.26.0, the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-24x9-r6q4-q93w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46634 Advisory: Twig: `template_from_string()` escapes a SourcePolicy-driven sandbox via synthesized template name IDs: CVE-2026-46634, GHSA-24x9-r6q4-q93w Record: https://patchnext.com/advisories/cve-2026-46634 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist twig/twig: affected >= 3.9.0, < 3.26.0; fixed in 3.26.0 ## Suggested inspection (read-only) - Packagist twig/twig: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on twig/twig. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-24x9-r6q4-q93w (GitHub-reviewed advisory GHSA-24x9-r6q4-q93w lists affected ranges: Packagist twig/twig >=3.9.0 <3.26.0) Commands are suggestions: review each one before running it.
Loading voting…