Twig: PHP code injection via {% use %} template name
CVE-2026-46633GHSA-7p85-w9px-jpjp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist twig/twig
- Affected
- >= 1.15.1, < 3.26.0
- Fixed in
- 3.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=0 <3.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=1.15.1 <3.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=1.15.1 <3.26.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-46633: 0.69% estimated exploitation activity in the next 30 days; percentile 52.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description `Compiler::string()` escapes `"`, `$`, `\`, NUL and TAB when generating PHP double-quoted string literals, but does not escape single quotes. In `ModuleNode::compileConstructor()`, the template name from a `{% use %}` tag is compiled via `subcompile()` -> `string()` and placed inside a surrounding PHP single-quoted string literal. A template name containing a single quote terminates that surrounding string early, allowing arbitrary PHP expressions to be injected into the compiled cache file. The injected code executes within the PHP process when the cache file is first loaded, bypassing the Twig sandbox entirely and achieving remote code execution. `SecurityPolicy` unconditionally allows `{% use %}` regardless of the configured `allowedTags`, so this primitive is reachable from sandboxed templates as well.
Resolution `Compiler::string()` now also escapes single quotes so that template names placed inside single-quoted PHP literals can no longer break out of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-7p85-w9px-jpjp
- Revision 2 · amended ·
Amended from ghsa record GHSA-7p85-w9px-jpjp
- Revision 1 · created ·
Published from ghsa record GHSA-7p85-w9px-jpjp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46633
Advisory: Twig: PHP code injection via `{% use %}` template name
IDs: CVE-2026-46633, GHSA-7p85-w9px-jpjp
Record: https://patchnext.com/advisories/cve-2026-46633 (revision 3, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.26.0. A vendor fix does not mean a deployment is fixed.
## Affected components
- Packagist twig/twig: affected >= 1.15.1, < 3.26.0; fixed in 3.26.0
## Suggested inspection (read-only)
- Packagist twig/twig: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twig/twig.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-7p85-w9px-jpjp (GitHub-reviewed advisory GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=0 <3.26.0)
- Verified: https://github.com/advisories/GHSA-7p85-w9px-jpjp (GitHub-reviewed advisory GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=1.15.1 <3.26.0)
- Verified: https://osv.dev/vulnerability/GHSA-7p85-w9px-jpjp (OSV record GHSA-7p85-w9px-jpjp lists affected ranges: Packagist twig/twig >=1.15.1 <3.26.0 (fixed))
Commands are suggestions: review each one before running it.Loading voting…