Twig: The spaceless filter implicitly marks its output as safe
CVE-2026-46628GHSA-4j38-f5cw-54h7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (twig/twig 3.26.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist twig/twig
- Affected
- < 3.26.0
- Fixed in
- 3.26.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4j38-f5cw-54h7 lists affected ranges: Packagist twig/twig >=0 <3.26.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2026-46628: 0.29% estimated exploitation activity in the next 30 days; percentile 22.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The spaceless filter is registered with issafe = ['html'], which means Twig's autoescaper does not escape its output in an HTML context. As a result, applying spaceless to attacker-controlled input that contains markup emits the markup unescaped even when the developer never wrote |raw and autoescape is enabled. Example: The filter is deprecated but still functional. With the deprecation, some downstream projects (e.g. Drupal modules) have duplicated the filter and inherited the same issafe flag. Resolution The spaceless filter no longer marks its output as safe. Documentation has been updated to warn that spaceless should not be applied to unsanitised user input. Credits Twig would like to thank Pierre Rudloff for reporting the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4j38-f5cw-54h7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46628 Advisory: Twig: The `spaceless` filter implicitly marks its output as safe IDs: CVE-2026-46628, GHSA-4j38-f5cw-54h7 Record: https://patchnext.com/advisories/cve-2026-46628 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: twig/twig 3.26.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist twig/twig: affected < 3.26.0; fixed in 3.26.0 ## Suggested inspection (read-only) - Packagist twig/twig: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on twig/twig. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4j38-f5cw-54h7 (GitHub-reviewed advisory GHSA-4j38-f5cw-54h7 lists affected ranges: Packagist twig/twig >=0 <3.26.0) Commands are suggestions: review each one before running it.
Loading voting…