Glances has Insecure Pickle Deserialization in its Version Cache that Leads to Arbitrary Code Execution
CVE-2026-46607GHSA-9837-48hr-q32j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- < 4.5.5
- Fixed in
- 4.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9837-48hr-q32j lists affected ranges: PyPI glances >=0 <4.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9837-48hr-q32j lists affected ranges: PyPI glances >=0 <4.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-46607: 0.19% estimated exploitation activity in the next 30 days; percentile 8.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary glances/outdated.py uses pickle.load() to read a version-check cache file stored at a predictable, world-accessible path (~/.cache/glances/glances-version.db or $XDGCACHEHOME/glances/glances-version.db). No integrity check, signature verification, or format validation is performed before deserialization. An attacker with write access to that path — through any of several realistic local or container-level scenarios — can plant a malicious pickle file and achieve arbitrary code execution as the OS user running Glances the next time it starts with version checking enabled (the default). --- Details Affected file: glances/outdated.py, method Outdated.loadcache(), line 121 Direct URL (commit 04579778e733d705898a169e049dc84772c852da): - https://github.com/nicolargo/glances/blob/04579778e733d705898a169e049dc84772c852da/glances/outdated.py#L121 self.cachefile is constructed from the XDG cache directory path at Outdated.init(): On a default Linux installation this resolves to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9837-48hr-q32j
- Revision 1 · created ·
Published from osv record GHSA-9837-48hr-q32j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46607 Advisory: Glances has Insecure Pickle Deserialization in its Version Cache that Leads to Arbitrary Code Execution IDs: CVE-2026-46607, GHSA-9837-48hr-q32j Record: https://patchnext.com/advisories/cve-2026-46607 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected < 4.5.5; fixed in 4.5.5 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9837-48hr-q32j (OSV record GHSA-9837-48hr-q32j lists affected ranges: PyPI glances >=0 <4.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-9837-48hr-q32j (GitHub-reviewed advisory GHSA-9837-48hr-q32j lists affected ranges: PyPI glances >=0 <4.5.5) Commands are suggestions: review each one before running it.
Loading voting…