Glances is Vulnerable to Command Injection via KVM/QEMU VM Domain Names in glances/plugins/vms/engines/virsh.py
CVE-2026-46606GHSA-v5r2-qh84-fjx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (glances 4.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI glances
- Affected
- < 4.5.5
- Fixed in
- 4.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v5r2-qh84-fjx5 lists affected ranges: PyPI glances >=0 <4.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5r2-qh84-fjx5 lists affected ranges: PyPI glances >=0 <4.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-46606: 0.19% estimated exploitation activity in the next 30 days; percentile 8.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Glances KVM/QEMU monitoring engine (glances/plugins/vms/engines/virsh.py) passes VM domain names, read directly from virsh list --all output, into f-string command templates that are processed by securepopen(). securepopen() is explicitly designed to interpret &&, |, and as shell operators. Because domain names are never sanitised before interpolation, any user with the ability to create or rename a KVM/QEMU virtual machine can execute arbitrary commands as the OS user running Glances — commonly root on hypervisor hosts. --- Details Affected file: glances/plugins/vms/engines/virsh.py Direct URLs (commit 04579778e733d705898a169e049dc84772c852da): - https://github.com/nicolargo/glances/blob/04579778e733d705898a169e049dc84772c852da/glances/plugins/vms/engines/virsh.py#L185 - https://github.com/nicolargo/glances/blob/04579778e733d705898a169e049dc84772c852da/glances/plugins/vms/engines/virsh.py#L204 The vulnerable calls are on lines 185 and 204: domain is the name string…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v5r2-qh84-fjx5
- Revision 1 · created ·
Published from osv record GHSA-v5r2-qh84-fjx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46606 Advisory: Glances is Vulnerable to Command Injection via KVM/QEMU VM Domain Names in glances/plugins/vms/engines/virsh.py IDs: CVE-2026-46606, GHSA-v5r2-qh84-fjx5 Record: https://patchnext.com/advisories/cve-2026-46606 (revision 2, source checked 26 Oct 2026, 13:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: glances 4.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI glances: affected < 4.5.5; fixed in 4.5.5 ## Suggested inspection (read-only) - `python -m pip show glances`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on glances. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v5r2-qh84-fjx5 (OSV record GHSA-v5r2-qh84-fjx5 lists affected ranges: PyPI glances >=0 <4.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-v5r2-qh84-fjx5 (GitHub-reviewed advisory GHSA-v5r2-qh84-fjx5 lists affected ranges: PyPI glances >=0 <4.5.5) Commands are suggestions: review each one before running it.
Loading voting…