nimiq-keys: Denial of service in Ed25519 multisig delinearization via invalid curve points
CVE-2026-46542GHSA-h9cc-w26m-j342
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nimiq-keys 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io nimiq-keys
- Affected
- < 1.4.0
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9cc-w26m-j342 lists affected ranges: crates.io nimiq-keys >=0 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-46542: 0.23% estimated exploitation activity in the next 30 days; percentile 14.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A denial-of-service vulnerability exists in the Ed25519 multisig delinearization code path. Ed25519PublicKey::delinearize() in keys/src/multisig/mod.rs called .unwrap() on curve point decompression, which panics when a public key is constructed from 32 bytes that do not represent a valid point on the Ed25519 curve. Ed25519PublicKey construction only validates byte length, not curve membership, so invalid keys can reach the delinearization path and crash the hosting process. A secondary panic existed in Commitment::From<[u8; 32], which similarly called .unwrap() on a failing curve point decompression. Who is affected: Browser and desktop wallet users of the web-client WASM library and the nimiq-wallet crate, when initiating a multisig operation with an attacker-supplied public key. An attacker must convince the user to include a crafted public key in a multisig setup — this is not a remotely triggerable node/validator crash. Who is NOT affected: Validator nodes, consensus,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h9cc-w26m-j342
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46542 Advisory: nimiq-keys: Denial of service in Ed25519 multisig delinearization via invalid curve points IDs: CVE-2026-46542, GHSA-h9cc-w26m-j342 Record: https://patchnext.com/advisories/cve-2026-46542 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nimiq-keys 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io nimiq-keys: affected < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - crates.io nimiq-keys: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nimiq-keys. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h9cc-w26m-j342 (GitHub-reviewed advisory GHSA-h9cc-w26m-j342 lists affected ranges: crates.io nimiq-keys >=0 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…