local-deep-research has an SSRF bypass in safe_get
CVE-2026-46526GHSA-g23j-2vwm-5c25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (local-deep-research 1.6.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI local-deep-research
- Affected
- < 1.6.10
- Fixed in
- 1.6.10
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g23j-2vwm-5c25 lists affected ranges: PyPI local-deep-research >=0 <1.6.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g23j-2vwm-5c25 lists affected ranges: PyPI local-deep-research >=0 <1.6.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- EPSS
- CVE-2026-46526: 0.30% estimated exploitation activity in the next 30 days; percentile 23.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The URL checking logic in local-deep-research has a logical flaw that could be bypassed by attackers, leading to SSRF attacks. Details The current project uses validateurl to validate the input URL. The main logic is to perform security checks on the host portion of the URL extracted by urlparse to prevent SSRF attacks. <img width="1173" height="1107" alt="QQ20260430-212334-30-1" src="https://github.com/user-attachments/assets/52b356aa-9ad3-4b1d-a472-39a2ada3ea23" / However, there are indeed differences in parsing between urlparse and the library that actually sends the request. For example, in safeget, validateurl is first used to perform an SSRF check, and then requests.get is used to send the actual request. <img width="1164" height="1089" alt="QQ20260430-212431-30-2" src="https://github.com/user-attachments/assets/f3decb16-4daa-49e0-861c-273a913487a0" / The core issue: urlparse() and requests disagree on which host a URL like http://127.0.0.1:6666\@1.1.1.1 points to: -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g23j-2vwm-5c25
- Revision 1 · created ·
Published from osv record GHSA-g23j-2vwm-5c25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46526 Advisory: local-deep-research has an SSRF bypass in `safe_get` IDs: CVE-2026-46526, GHSA-g23j-2vwm-5c25 Record: https://patchnext.com/advisories/cve-2026-46526 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: local-deep-research 1.6.10. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI local-deep-research: affected < 1.6.10; fixed in 1.6.10 ## Suggested inspection (read-only) - `python -m pip show local-deep-research`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on local-deep-research. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g23j-2vwm-5c25 (OSV record GHSA-g23j-2vwm-5c25 lists affected ranges: PyPI local-deep-research >=0 <1.6.10 (fixed)) - Verified: https://github.com/advisories/GHSA-g23j-2vwm-5c25 (GitHub-reviewed advisory GHSA-g23j-2vwm-5c25 lists affected ranges: PyPI local-deep-research >=0 <1.6.10) Commands are suggestions: review each one before running it.
Loading voting…