Skip to content

← Actionable
High, CVSS 8.8amended

MCP Server Kubernetes: Tool Access Control Bypass via Presentation-Layer Filtering Without Execution-Layer Enforcement

CVE-2026-46519GHSA-cr22-wjx7-2w6m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-kubernetes 3.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-46519: 0.51% estimated exploitation activity in the next 30 days; percentile 43.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary mcp-server-kubernetes exposes three environment variables (ALLOWONLYREADONLYTOOLS, ALLOWONLYNONDESTRUCTIVETOOLS, ALLOWEDTOOLS) documented as access controls for restricting which Kubernetes operations are available. These controls are enforced at the tool discovery layer (tools/list) but not at the execution layer (tools/call). Any client that knows a tool name can invoke it directly regardless of the configured restriction mode. The access control was effectively cosmetic. Fixed in v3.6.0. Impact An attacker or misconfigured AI agent with network access to the MCP server's HTTP endpoint could invoke any Kubernetes tool regardless of the restriction mode configured by the operator -- including kubectldelete, execinpod, kubectlgeneric, and nodemanagement. The project explicitly supports and documents multi-client HTTP deployment scenarios (Streamable HTTP and SSE transports, in-cluster deployments, Codex CLI and Gemini CLI integrations). In these deployments, operators relied…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cr22-wjx7-2w6m

  2. Revision 1 · created ·

    Published from osv record GHSA-cr22-wjx7-2w6m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46519

Advisory: MCP Server Kubernetes: Tool Access Control Bypass via Presentation-Layer Filtering Without Execution-Layer Enforcement
IDs: CVE-2026-46519, GHSA-cr22-wjx7-2w6m
Record: https://patchnext.com/advisories/cve-2026-46519 (revision 2, source checked 26 Oct 2026, 12:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-server-kubernetes 3.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mcp-server-kubernetes: affected < 3.6.0; fixed in 3.6.0

## Suggested inspection (read-only)
- `npm ls mcp-server-kubernetes --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-server-kubernetes.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cr22-wjx7-2w6m (OSV record GHSA-cr22-wjx7-2w6m lists affected ranges: npm mcp-server-kubernetes >=0 <3.6.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cr22-wjx7-2w6m (GitHub-reviewed advisory GHSA-cr22-wjx7-2w6m lists affected ranges: npm mcp-server-kubernetes >=0 <3.6.0)

Commands are suggestions: review each one before running it.

Loading voting…