Skip to content

← Actionable
High, CVSS 7.8amended

lmdeploy: Hardcoded trust_remote_code=True is an implicit unsafe remote-code load path with no user opt-out

CVE-2026-46517GHSA-9xq9-36w5-q796

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lmdeploy 0.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lmdeploy

    Affected
    <= 0.12.3
    Fixed in
    0.13.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 Β· CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-46517: 0.16% estimated exploitation activity in the next 30 days; percentile 5.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

πŸ“‹ Reframing (2026-05-02): implicit unsafe remote-code path, not "supply-chain" The accurate description of this vulnerability is: "getmodelarch and related helpers hardcode trustremotecode=True with no opt-out, creating an implicit unsafe remote-code load path on every model fetch." What this report does NOT claim: It is NOT a network-attack RCE β€” the user supplies the model reference; LMDeploy honors it. It is NOT a "supply chain" CVE in the classical sense (where a benign upstream is compromised) β€” the user explicitly types the repo name. What this report DOES claim: Other inference frameworks (vLLM, TGI, Hugging Face transformers itself) all expose --trust-remote-code as opt-in so that users who consciously load known-safe repos can opt in, while users following a tutorial cannot accidentally execute attacker Python by typing a wrong repo name. LMDeploy's hardcoded True is an implicit trust-boundary override that violates HF Transformers' default-secure stance…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 Β· amended Β·

    Amended from ghsa record GHSA-9xq9-36w5-q796

  2. Revision 1 Β· created Β·

    Published from osv record GHSA-9xq9-36w5-q796

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46517

Advisory: lmdeploy: Hardcoded trust_remote_code=True is an implicit unsafe remote-code load path with no user opt-out
IDs: CVE-2026-46517, GHSA-9xq9-36w5-q796
Record: https://patchnext.com/advisories/cve-2026-46517 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lmdeploy 0.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lmdeploy: affected <= 0.12.3; fixed in 0.13.0

## Suggested inspection (read-only)
- `python -m pip show lmdeploy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lmdeploy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9xq9-36w5-q796 (OSV record GHSA-9xq9-36w5-q796 lists affected ranges: PyPI lmdeploy >=0 <0.13.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9xq9-36w5-q796 (GitHub-reviewed advisory GHSA-9xq9-36w5-q796 lists affected ranges: PyPI lmdeploy >=0 <=0.12.3)

Commands are suggestions: review each one before running it.

Loading voting…