OpenAM Arbitrary OAuth Token Minting via Push Registration
CVE-2026-46498GHSA-cj8f-2fhf-826r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.openam:openam-oauth2 16.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.openidentityplatform.openam:openam-oauth2
- Affected
- < 16.1.1
- Fixed in
- 16.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cj8f-2fhf-826r lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <16.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cj8f-2fhf-826r lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <16.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-46498: 0.41% estimated exploitation activity in the next 30 days; percentile 35.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Description An Authorization Bypass Through User-Controlled Key (CWE-639) exists in OpenAM's stateful OAuth2 token-read path. Under certain conditions, this may allow an attacker to forge OAuth2 bearer tokens and OIDC ID tokens with arbitrary subject, client, realm, and scope. This affects OpenAM Community Edition through version 16.0.6. The OAuth2 token-read path reads caller-supplied token identifiers from the shared Core Token Store (CTS) without placing them in an OAuth-only namespace and without binding the row's trusted CTS type to the expected OAuth token family, so any CTS row whose BLOB claims to be an OAuth token is accepted on the read path with no integrity check.
Impact OpenAM Community Edition deployments through version 16.0.6 with the OAuth2 Provider service enabled in a realm are potentially affected, but the vulnerable read path is only reachable once an attacker can place attacker-controlled JSON into the shared CTS under an identifier they know.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-cj8f-2fhf-826r
- Revision 2 · amended ·
Amended from ghsa record GHSA-cj8f-2fhf-826r
- Revision 1 · created ·
Published from ghsa record GHSA-cj8f-2fhf-826r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46498 Advisory: OpenAM Arbitrary OAuth Token Minting via Push Registration IDs: CVE-2026-46498, GHSA-cj8f-2fhf-826r Record: https://patchnext.com/advisories/cve-2026-46498 (revision 3, source checked 29 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.openam:openam-oauth2 16.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.openidentityplatform.openam:openam-oauth2: affected < 16.1.1; fixed in 16.1.1 ## Suggested inspection (read-only) - Maven org.openidentityplatform.openam:openam-oauth2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.openidentityplatform.openam:openam-oauth2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cj8f-2fhf-826r (GitHub-reviewed advisory GHSA-cj8f-2fhf-826r lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <16.1.1) - Verified: https://osv.dev/vulnerability/GHSA-cj8f-2fhf-826r (OSV record GHSA-cj8f-2fhf-826r lists affected ranges: Maven org.openidentityplatform.openam:openam-oauth2 >=0 <16.1.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…