HAX CMS: Stored XSS via ' ' component allows arbitrary JavaScript execution and token theft
CVE-2026-46496GHSA-2m6p-hm3w-6jm3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/haxcms-nodejs 26.0.0; @haxtheweb/video-player 26.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 25.0.0
- Fixed in
- 26.0.0
- Affected
- <= 25.0.0
- Fixed in
- 26.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2m6p-hm3w-6jm3 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <26.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2m6p-hm3w-6jm3 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <=25.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-46496: 0.23% estimated exploitation activity in the next 30 days; percentile 13.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A stored cross-site scripting (XSS) vulnerability exists in HAX CMS due to improper sanitization of the <video-player component. The component allows javascript: URIs in the source attribute, which are executed when the page is viewed. This enables attackers to execute arbitrary JavaScript in the context of the victim’s browser and access sensitive data such as JWT tokens and more. Details The vulnerability is present in the <video-player web component used within the HAX CMS editor. The application fails to validate or sanitize user-supplied input in the following attributes: - source - source-data These attributes accept arbitrary URI schemes, including javascript:, which leads to execution of attacker-controlled JavaScript in the browser. Example vulnerable usage: Because this content is stored and rendered to other users, the vulnerability is classified as a stored XSS. The root cause is the lack of URI scheme validation and improper sanitization of component attributes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2m6p-hm3w-6jm3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2m6p-hm3w-6jm3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46496 Advisory: HAX CMS: Stored XSS via ' ' component allows arbitrary JavaScript execution and token theft IDs: CVE-2026-46496, GHSA-2m6p-hm3w-6jm3 Record: https://patchnext.com/advisories/cve-2026-46496 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/haxcms-nodejs 26.0.0; @haxtheweb/video-player 26.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @haxtheweb/haxcms-nodejs: affected <= 25.0.0; fixed in 26.0.0 - npm @haxtheweb/video-player: affected <= 25.0.0; fixed in 26.0.0 ## Suggested inspection (read-only) - `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @haxtheweb/video-player --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @haxtheweb/haxcms-nodejs, @haxtheweb/video-player. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2m6p-hm3w-6jm3 (OSV record GHSA-2m6p-hm3w-6jm3 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <26.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2m6p-hm3w-6jm3 (GitHub-reviewed advisory GHSA-2m6p-hm3w-6jm3 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 <=25.0.0) Commands are suggestions: review each one before running it.
Loading voting…