Skip to content

← Actionable
Critical, CVSS 9.2

OpenDJ Pre-Auth RCE via Java Deserialization in JMX RMI

CVE-2026-46495GHSA-43x2-g84q-fmqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.openidentityplatform.opendj:opendj-server-legacy 5.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-46495: 1.13% estimated exploitation activity in the next 30 days; percentile 66.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Description A Deserialization of Untrusted Data (CWE-502) issue in OpenDJ's JMX RMI connector allows an unauthenticated remote attacker to deserialize arbitrary Java objects on the server. The vulnerability exists because the platform reads and processes attacker-controlled bytes prior to authentication. This affects OpenDJ Community Edition through 5.1.0. This has been patched in version 5.1.1. Impact This impacts all current OpenDJ releases where the JMX Connection Handler is enabled. While disabled by default, it is frequently enabled in practice for monitoring integrations. Exploitation requires TCP reachability to the configured listener and does not require authentication, prior privileges, or client certificates. Successful exploitation results in unauthenticated Remote Code Execution (RCE), with the severity depending on the runtime classpath and Java version. Unauthenticated RCE was demonstrated on the OpenDJ 4.4.15 (JDK 11 + Jackson 2.12.6.1). Patch This has been…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43x2-g84q-fmqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46495

Advisory: OpenDJ Pre-Auth RCE via Java Deserialization in JMX RMI
IDs: CVE-2026-46495, GHSA-43x2-g84q-fmqx
Record: https://patchnext.com/advisories/cve-2026-46495 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.openidentityplatform.opendj:opendj-server-legacy 5.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.openidentityplatform.opendj:opendj-server-legacy: affected <= 5.1.0; fixed in 5.1.1

## Suggested inspection (read-only)
- Maven org.openidentityplatform.opendj:opendj-server-legacy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.openidentityplatform.opendj:opendj-server-legacy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43x2-g84q-fmqx (GitHub-reviewed advisory GHSA-43x2-g84q-fmqx lists affected ranges: Maven org.openidentityplatform.opendj:opendj-server-legacy >=0 <=5.1.0)

Commands are suggestions: review each one before running it.

Loading voting…