motionEye: Authentication possible via password hash
CVE-2026-46488GHSA-r3cw-c95m-wfh9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (motioneye 0.44.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI motioneye
- Affected
- < 0.44.0
- Fixed in
- 0.44.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3cw-c95m-wfh9 lists affected ranges: PyPI motioneye >=0 <0.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r3cw-c95m-wfh9 lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-46488: 0.46% estimated exploitation activity in the next 30 days; percentile 40.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An authentication bypass vulnerability exists due to improper trust in client-controlled cookies. The application accepts user-supplied cookie values containing a username and password-hash-derived value as sufficient authentication material. These cookies can be set or modified prior to login, allowing an unauthenticated attacker to impersonate arbitrary users without knowledge of the plaintext password. This issue stems from the absence of server-side validation of authentication state and reliance on attacker-controlled cookie data Details The vulnerability arises because the application accepts the client-supplied cookies named meyepasswordhash and meyeusername as sufficient authentication material. The server does not validate these values against a server-side session or enforce proper authentication checks before establishing an authenticated state. As a result, an unauthenticated attacker can set or modify these cookies to impersonate another user if the target…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-r3cw-c95m-wfh9
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-r3cw-c95m-wfh9
- Revision 1 · created ·
Published from ghsa record GHSA-r3cw-c95m-wfh9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46488 Advisory: motionEye: Authentication possible via password hash IDs: CVE-2026-46488, GHSA-r3cw-c95m-wfh9 Record: https://patchnext.com/advisories/cve-2026-46488 (revision 4, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: motioneye 0.44.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI motioneye: affected < 0.44.0; fixed in 0.44.0 ## Suggested inspection (read-only) - `python -m pip show motioneye`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on motioneye. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r3cw-c95m-wfh9 (GitHub-reviewed advisory GHSA-r3cw-c95m-wfh9 lists affected ranges: PyPI motioneye >=0 <0.44.0) - Verified: https://osv.dev/vulnerability/GHSA-r3cw-c95m-wfh9 (OSV record GHSA-r3cw-c95m-wfh9 lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…