Skip to content

← Actionable
Medium, CVSS 4.3

Mattermost doesn't validate user-supplied input in API request handlers

CVE-2026-4646GHSA-rmvv-8v8w-rf7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost-plugin-github 1.0.1-0.20260330164815-c2840e980b3c; github.com/mattermost/mattermost-server 11.6.1, 11.5.4, 11.4.5, 10.11.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-rmvv-8v8w-rf7x lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =11.4.0 =10.11.0 =0 <1.0.1-0.20260330164815-c2840e980b3c

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-4646: 0.25% estimated exploitation activity in the next 30 days; percentile 16.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint. Mattermost Advisory ID: MMSA-2026-00638

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rmvv-8v8w-rf7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-4646

Advisory: Mattermost doesn't validate user-supplied input in API request handlers
IDs: CVE-2026-4646, GHSA-rmvv-8v8w-rf7x
Record: https://patchnext.com/advisories/cve-2026-4646 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost-plugin-github 1.0.1-0.20260330164815-c2840e980b3c; github.com/mattermost/mattermost-server 11.6.1, 11.5.4, 11.4.5, 10.11.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost-plugin-github: affected < 1.0.1-0.20260330164815-c2840e980b3c; fixed in 1.0.1-0.20260330164815-c2840e980b3c
- Go github.com/mattermost/mattermost-server: affected >= 11.6.0, <= 11.6.0; >= 11.5.0, < 11.5.4; >= 11.4.0, < 11.4.5; >= 10.11.0, < 10.11.15; fixed in 10.11.15, 11.4.5, 11.5.4, 11.6.1

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost-plugin-github: check the installed version with your package manager.
- Go github.com/mattermost/mattermost-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost-plugin-github, github.com/mattermost/mattermost-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rmvv-8v8w-rf7x (GitHub-reviewed advisory GHSA-rmvv-8v8w-rf7x lists affected ranges: Go github.com/mattermost/mattermost-server >=11.6.0 =11.5.0 =11.4.0 =10.11.0 =0 <1.0.1-0.20260330164815-c2840e980b3c)

Commands are suggestions: review each one before running it.

Loading voting…