Skip to content

← Actionable
Critical, CVSS 9.4amended

FlowiseAI: Authenticated Host RCE via POST /api/v1/node-custom-function and NodeVM Sandbox Escape

CVE-2026-46442GHSA-9rvc-vf7m-pgm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flowise 3.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flowise

    Affected
    <= 3.1.1
    Fixed in
    3.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-46442: 36.34% estimated exploitation activity in the next 30 days; percentile 98.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary POST /api/v1/node-custom-function lacks route-level authorization, allowing any authenticated user or API key to submit arbitrary JavaScript to the Custom JS Function node. When E2BAPIKEY is not configured — the common deployment case — Flowise executes this code inside a NodeVM sandbox. This sandbox can be escaped, allowing an attacker to reach the host process object and execute system commands via childprocess. The result is authenticated remote code execution on the Flowise server host. CVSS v3.1: AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H = 9.9 Critical. Details Two distinct security boundaries are violated. 1. Missing route-level authorization packages/server/src/routes/node-custom-functions/index.ts registers the endpoint with no permission middleware: Other sensitive routes in the same codebase use explicit permission gates: Global /api/v1 authentication still applies, so this is not unauthenticated — but any valid session or API key reaches the endpoint without further…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-9rvc-vf7m-pgm2

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-9rvc-vf7m-pgm2

  4. Revision 1 · created ·

    Published from ghsa record GHSA-9rvc-vf7m-pgm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46442

Advisory: FlowiseAI: Authenticated Host RCE via POST /api/v1/node-custom-function and NodeVM Sandbox Escape
IDs: CVE-2026-46442, GHSA-9rvc-vf7m-pgm2
Record: https://patchnext.com/advisories/cve-2026-46442 (revision 4, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flowise 3.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flowise: affected <= 3.1.1; fixed in 3.1.2

## Suggested inspection (read-only)
- `npm ls flowise --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flowise.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9rvc-vf7m-pgm2 (GitHub-reviewed advisory GHSA-9rvc-vf7m-pgm2 lists affected ranges: npm flowise >=0 <=3.1.1)
- Verified: https://osv.dev/vulnerability/GHSA-9rvc-vf7m-pgm2 (OSV record GHSA-9rvc-vf7m-pgm2 lists affected ranges: npm flowise >=0 <3.1.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…