LMDeploy: Arbitrary code execution via hardcoded trust_remote_code=True in lmdeploy model initialization
CVE-2026-46432GHSA-m549-qq94-fvhg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lmdeploy 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lmdeploy
- Affected
- < 0.13.0
- Fixed in
- 0.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m549-qq94-fvhg lists affected ranges: PyPI lmdeploy >=0 <0.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m549-qq94-fvhg lists affected ranges: PyPI lmdeploy >=0 <0.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-46432: 0.14% estimated exploitation activity in the next 30 days; percentile 3.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary lmdeploy hardcodes trustremotecode=True in multiple HuggingFace model-loading call sites. The affected code paths are in: The vulnerable call sites pass trustremotecode=True into HuggingFace Transformers APIs such as AutoConfig.frompretrained(), PretrainedConfig.getconfigdict(), and GenerationConfig.frompretrained(). Because the model path is supplied by the operator or deployment configuration, an attacker who can control the modelpath used by an lmdeploy serving process can point it to an attacker-controlled HuggingFace model repository. When lmdeploy starts and initializes the model, Transformers may download and execute remote Python code from that repository. Successful exploitation results in arbitrary code execution with the privileges of the lmdeploy serving process. Affected version Confirmed affected: The issue was verified on v0.12.3 and on main. Vulnerable code Confirmed call sites: The vulnerable pattern is: and: The risk is that trustremotecode=True is enabled…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m549-qq94-fvhg
- Revision 1 · created ·
Published from osv record GHSA-m549-qq94-fvhg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46432 Advisory: LMDeploy: Arbitrary code execution via hardcoded trust_remote_code=True in lmdeploy model initialization IDs: CVE-2026-46432, GHSA-m549-qq94-fvhg Record: https://patchnext.com/advisories/cve-2026-46432 (revision 2, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lmdeploy 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lmdeploy: affected < 0.13.0; fixed in 0.13.0 ## Suggested inspection (read-only) - `python -m pip show lmdeploy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lmdeploy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m549-qq94-fvhg (OSV record GHSA-m549-qq94-fvhg lists affected ranges: PyPI lmdeploy >=0 <0.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-m549-qq94-fvhg (GitHub-reviewed advisory GHSA-m549-qq94-fvhg lists affected ranges: PyPI lmdeploy >=0 <0.13.0) Commands are suggestions: review each one before running it.
Loading voting…