Skip to content

← Actionable
Medium, CVSS 5.6

Setup PHP: Command Injection in Repository-Derived PHP Version Resolution

CVE-2026-46420GHSA-pqwm-q9pv-ph8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (shivammathur/setup-php 2.37.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-46420: 2.01% estimated exploitation activity in the next 30 days; percentile 80.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A command injection vulnerability was identified in shivammathur/setup-php when the action resolves the PHP version from repository-controlled files and uses that value while generating the platform setup script. In affected versions, setup-php may read the PHP version from: - .php-version - composer.lock via platform-overrides.php - composer.json via config.platform.php If an attacker can influence one of these files and the workflow executes setup-php in a trusted context, they may be able to execute commands on the GitHub Actions runner. Impact This issue is exploitable when setup-php is run after checking out attacker-controlled repository contents and resolves the PHP version from repository files. The most significant example is a privileged workflow such as pullrequesttarget that checks out untrusted pull request code before invoking setup-php. Similar risk can also arise in other workflows that operate on attacker-controlled refs, branches, or repository contents in a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pqwm-q9pv-ph8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46420

Advisory: Setup PHP: Command Injection in Repository-Derived PHP Version Resolution
IDs: CVE-2026-46420, GHSA-pqwm-q9pv-ph8r
Record: https://patchnext.com/advisories/cve-2026-46420 (revision 1, source checked 26 Oct 2026, 17:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: shivammathur/setup-php 2.37.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- GitHub Actions shivammathur/setup-php: affected >= 2.25.0, < 2.37.1; fixed in 2.37.1

## Suggested inspection (read-only)
- GitHub Actions shivammathur/setup-php: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on shivammathur/setup-php.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pqwm-q9pv-ph8r (GitHub-reviewed advisory GHSA-pqwm-q9pv-ph8r lists affected ranges: GitHub Actions shivammathur/setup-php >=2.25.0 <2.37.1)

Commands are suggestions: review each one before running it.

Loading voting…