Skip to content

← Actionable
High, CVSS 8.2

Caddy Defender trusted proxy client IP bypass

CVE-2026-46415GHSA-3h23-rrpc-3p87

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pkg.jsn.cam/caddy-defender 0.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-46415: 0.23% estimated exploitation activity in the next 30 days; percentile 14.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Caddy Defender used r.RemoteAddr when evaluating whether a request should be blocked. RemoteAddr is the address of the immediate peer connected to Caddy. In deployments where Caddy is behind a trusted proxy, CDN, or load balancer, the immediate peer is usually the proxy, not the original client. Caddy resolves the original client address into its clientip request variable after applying the configured trustedproxies policy, but Defender did not use that value. As a result, clients from blocked IP ranges could bypass Defender when accessing Caddy through a trusted proxy whose own IP address was not blocked. This affects deployments that use Defender behind trusted proxies and expect it to enforce blocking based on the real client IP. Patches The issue is fixed by making Defender prefer Caddys resolved clientip request variable when it is available. Defender falls back to RemoteAddr only when Caddy has not provided a resolved client IP. Users should upgrade to v0.10.1 or later.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3h23-rrpc-3p87

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46415

Advisory: Caddy Defender trusted proxy client IP bypass
IDs: CVE-2026-46415, GHSA-3h23-rrpc-3p87
Record: https://patchnext.com/advisories/cve-2026-46415 (revision 1, source checked 26 Oct 2026, 15:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pkg.jsn.cam/caddy-defender 0.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go pkg.jsn.cam/caddy-defender: affected < 0.10.1; fixed in 0.10.1

## Suggested inspection (read-only)
- Go pkg.jsn.cam/caddy-defender: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pkg.jsn.cam/caddy-defender.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3h23-rrpc-3p87 (GitHub-reviewed advisory GHSA-3h23-rrpc-3p87 lists affected ranges: Go pkg.jsn.cam/caddy-defender >=0 <0.10.1)

Commands are suggestions: review each one before running it.

Loading voting…