Skip to content

← Actionable
High, CVSS 8.6amended

Stored XSS via in HAX CMS allows access to sensitive client-side data and account takeover

CVE-2026-46396GHSA-jh3h-rpxg-fr36

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/iframe-loader 26.0.0; @haxtheweb/haxcms-nodejs 26.0.0; @haxtheweb/video-player 26.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-46396: 0.23% estimated exploitation activity in the next 30 days; percentile 13.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A stored cross-site scripting (XSS) vulnerability exists in HAX CMS due to improper sanitization of <iframe elements. The application allows javascript: URIs in the src attribute, which are executed when a malicious page is viewed. This enables attackers to execute arbitrary JavaScript in the context of the victim’s browser and access sensitive data exposed to client-side scripts. Details Successful exploitation allows access to any data available in the browser context, including: - Authentication tokens (e.g., JWT) - Session cookies (if not protected with HttpOnly) - Application configuration (e.g., window.appSettings) - User-specific data accessible via APIs This significantly increases the impact beyond simple script execution. PoC Steps to reproduce: 1. Log in to HAX CMS as any authenticated user. 2. Create a new page or edit an existing page. 3. Open the HTML source editor (<). 4. Insert the following payload: <img width="2446" height="1319" alt="image"…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jh3h-rpxg-fr36

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jh3h-rpxg-fr36

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-46396

Advisory: Stored XSS via in HAX CMS allows access to sensitive client-side data and account takeover
IDs: CVE-2026-46396, GHSA-jh3h-rpxg-fr36
Record: https://patchnext.com/advisories/cve-2026-46396 (revision 3, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/iframe-loader 26.0.0; @haxtheweb/haxcms-nodejs 26.0.0; @haxtheweb/video-player 26.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @haxtheweb/iframe-loader: affected <= 25.0.0; fixed in 26.0.0
- npm @haxtheweb/haxcms-nodejs: affected <= 25.0.0; fixed in 26.0.0
- npm @haxtheweb/video-player: affected <= 25.0.0; fixed in 26.0.0

## Suggested inspection (read-only)
- `npm ls @haxtheweb/iframe-loader --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @haxtheweb/haxcms-nodejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @haxtheweb/video-player --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @haxtheweb/iframe-loader, @haxtheweb/haxcms-nodejs, @haxtheweb/video-player.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jh3h-rpxg-fr36 (OSV record GHSA-jh3h-rpxg-fr36 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 =0 <26.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-jh3h-rpxg-fr36 (GitHub-reviewed advisory GHSA-jh3h-rpxg-fr36 lists affected ranges: npm @haxtheweb/haxcms-nodejs >=0 =0 =0 <=25.0.0)

Commands are suggestions: review each one before running it.

Loading voting…