HAX open-apis: Credential Theft via Server-Side Request Forgery (SSRF) in open-apis
CVE-2026-46391GHSA-4fg7-f244-3j49
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@haxtheweb/open-apis 26.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 26.0.0
- Fixed in
- 26.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4fg7-f244-3j49 lists affected ranges: npm @haxtheweb/open-apis >=0 <26.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4fg7-f244-3j49 lists affected ranges: npm @haxtheweb/open-apis >=0 <26.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2026-46391: 0.46% estimated exploitation activity in the next 30 days; percentile 39.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple functions conduct substring-only matching to validate hostnames to which basic authorization should be sent. An attacker can append the matched substrings to an attacker-controlled endpoint and capture authentication. Details api/services/website/cacheAddress.js, api/apps/haxcms/lib/JOSHelpers.js, and api/apps/haxcms/convert/elmslnToSite.js use similar logic to check for hard-coded site names. However, the logic only looks for the substring to be included in the user-controlled string, allowing an attacker to craft an API call and extract the credentials intended for the hard-coded domains. PoC Making API calls to an affected endpoint will result in credential theft. The attacker-controlled domains in these proofs of concept are cloudflared tunnels, protecting the production credentials from unencrypted exposure. cacheAddress.js: <img width="3404" height="1656" alt="ssrfcredtheft" src="https://github.com/user-attachments/assets/0a87cef5-3c4d-450a-8bb7-35123d5f621b" /…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-4fg7-f244-3j49
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-4fg7-f244-3j49
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46391 Advisory: HAX open-apis: Credential Theft via Server-Side Request Forgery (SSRF) in open-apis IDs: CVE-2026-46391, GHSA-4fg7-f244-3j49 Record: https://patchnext.com/advisories/cve-2026-46391 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @haxtheweb/open-apis 26.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @haxtheweb/open-apis: affected < 26.0.0; fixed in 26.0.0 ## Suggested inspection (read-only) - `npm ls @haxtheweb/open-apis --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @haxtheweb/open-apis. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4fg7-f244-3j49 (OSV record GHSA-4fg7-f244-3j49 lists affected ranges: npm @haxtheweb/open-apis >=0 <26.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-4fg7-f244-3j49 (GitHub-reviewed advisory GHSA-4fg7-f244-3j49 lists affected ranges: npm @haxtheweb/open-apis >=0 <26.0.0) Commands are suggestions: review each one before running it.
Loading voting…