Microsoft APM: Windows absolute-path tar member overwrite during legacy-bundle probing in apm install
CVE-2026-46383GHSA-mq5j-pw29-jcv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apm-cli 0.13.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apm-cli
- Affected
- <= 0.12.4
- Fixed in
- 0.13.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mq5j-pw29-jcv3 lists affected ranges: PyPI apm-cli >=0 <0.13.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq5j-pw29-jcv3 lists affected ranges: PyPI apm-cli >=0 <=0.12.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-46383: 0.45% estimated exploitation activity in the next 30 days; percentile 39.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Microsoft APM contains a Windows-specific archive extraction boundary failure in the legacy-bundle probe used by apm install <bundle on supported Python 3.10 and 3.11 runtimes. When apm install is given a local .tar.gz that is not recognized as a plugin-format bundle, APM probes whether it is a legacy --format apm bundle. On Python versions earlier than 3.12, that probe extracts untrusted tar members with raw tar.extractall() without rejecting Windows absolute member names such as D:/.... This issue is still present on the latest main commit at review time (2b7a931d58a73cbfc0bcf086cea332d204075e27) and on the latest release (v0.12.4). In both cases, a crafted legacy-looking tarball caused an external file to be created or overwritten outside the temporary extraction root before apm install finished rejecting the bundle with the expected legacy-format usage error. This report is scoped narrowly to Windows installations running Python 3.10 or 3.11. Details The broken trust…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mq5j-pw29-jcv3
- Revision 1 · created ·
Published from osv record GHSA-mq5j-pw29-jcv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46383 Advisory: Microsoft APM: Windows absolute-path tar member overwrite during legacy-bundle probing in `apm install` IDs: CVE-2026-46383, GHSA-mq5j-pw29-jcv3 Record: https://patchnext.com/advisories/cve-2026-46383 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apm-cli 0.13.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apm-cli: affected <= 0.12.4; fixed in 0.13.0 ## Suggested inspection (read-only) - `python -m pip show apm-cli`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apm-cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mq5j-pw29-jcv3 (OSV record GHSA-mq5j-pw29-jcv3 lists affected ranges: PyPI apm-cli >=0 <0.13.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mq5j-pw29-jcv3 (GitHub-reviewed advisory GHSA-mq5j-pw29-jcv3 lists affected ranges: PyPI apm-cli >=0 <=0.12.4) Commands are suggestions: review each one before running it.
Loading voting…