compliance-trestle Vulnerable to SSRF in Remote Fetching Subsystem
CVE-2026-46380GHSA-w76h-q7c6-jpjp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (compliance-trestle 4.0.3, 3.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI compliance-trestle
- Affected
- >= 4.0.0, < 4.0.3< 3.12.2
- Fixed in
- 3.12.2, 4.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w76h-q7c6-jpjp lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w76h-q7c6-jpjp lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.7 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-46380: 0.14% estimated exploitation activity in the next 30 days; percentile 3.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A source code audit led to the discovery of three significant security vulnerabilities in the trestle/core/remote/cache.py module. Finding 1 (Critical): SSRF (CWE-918) The HTTPSFetcher.dofetch() method passes a user-supplied URL directly to requests.get() without validation. This allows an attacker to perform Server-Side Request Forgery, targeting internal services or cloud metadata endpoints (e.g., 169.254.169.254). Per rule 4.2.11 of the CVE CNA rules Finding 1 will be addressed in this advisory, while findings 2 & 3 will be addressed in separate advisories: --- Multiple Path Traversal Vulnerabilities in Remote Fetching Subsystem Finding 2 & 3 (High/Medium): Path Traversal (CWE-22) The caching logic for HTTPSFetcher and LocalFetcher fails to sanitize URI paths, allowing for arbitrary file reads via file:// or writing cached files outside the intended directory. Impact: These vulnerabilities can be chained to exfiltrate sensitive cloud credentials or compromise CI/CD environments.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w76h-q7c6-jpjp
- Revision 1 · created ·
Published from osv record GHSA-w76h-q7c6-jpjp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46380 Advisory: compliance-trestle Vulnerable to SSRF in Remote Fetching Subsystem IDs: CVE-2026-46380, GHSA-w76h-q7c6-jpjp Record: https://patchnext.com/advisories/cve-2026-46380 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: compliance-trestle 4.0.3, 3.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI compliance-trestle: affected >= 4.0.0, < 4.0.3; < 3.12.2; fixed in 3.12.2, 4.0.3 ## Suggested inspection (read-only) - `python -m pip show compliance-trestle`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on compliance-trestle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w76h-q7c6-jpjp (OSV record GHSA-w76h-q7c6-jpjp lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2 (fixed)) - Verified: https://github.com/advisories/GHSA-w76h-q7c6-jpjp (GitHub-reviewed advisory GHSA-w76h-q7c6-jpjp lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2) Commands are suggestions: review each one before running it.
Loading voting…