SillyTavern: SSRF in SearXNG Search Proxy via Unvalidated baseUrl
CVE-2026-46372GHSA-qg89-qwwh-5f3j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sillytavern 1.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm sillytavern
- Affected
- <= 1.17.0
- Fixed in
- 1.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qg89-qwwh-5f3j lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qg89-qwwh-5f3j lists affected ranges: npm sillytavern >=0 <=1.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2026-46372: 0.87% estimated exploitation activity in the next 30 days; percentile 58.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Resolution SillyTavern 1.18.0 added a generic server-side request filter (Private Request Whitelisting). Since we expect users to use the application in a trusted environment, the filter is disabled by default, however it is strongly advised to be enabled and properly configured when an instance is being hosted over a network, as suggested by a console warning message and an officially published security checklist for administrators. Documentation: - https://docs.sillytavern.app/administration/config-yaml/#private-address-whitelisting - https://docs.sillytavern.app/administration/#security-checklist Note on future SSRF findings Since the request filter applies to the entire application, no SSRF vulnerabilities against individual endpoints will be accepted, unless it has been proven that a properly configured and enabled filter can be bypassed in an undocumented way. Only advisories disclosed before the 1.18.0 release will be posted if their concern is SSRF. Summary SillyTavern 1.17.0…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qg89-qwwh-5f3j
- Revision 1 · created ·
Published from osv record GHSA-qg89-qwwh-5f3j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46372 Advisory: SillyTavern: SSRF in SearXNG Search Proxy via Unvalidated baseUrl IDs: CVE-2026-46372, GHSA-qg89-qwwh-5f3j Record: https://patchnext.com/advisories/cve-2026-46372 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sillytavern 1.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm sillytavern: affected <= 1.17.0; fixed in 1.18.0 ## Suggested inspection (read-only) - `npm ls sillytavern --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sillytavern. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qg89-qwwh-5f3j (OSV record GHSA-qg89-qwwh-5f3j lists affected ranges: npm sillytavern >=0 <1.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-qg89-qwwh-5f3j (GitHub-reviewed advisory GHSA-qg89-qwwh-5f3j lists affected ranges: npm sillytavern >=0 <=1.17.0) Commands are suggestions: review each one before running it.
Loading voting…