Fleet has observer-level enrollment secret extraction via ORDER BY oracle on labels host-listing endpoint
CVE-2026-46370GHSA-vxm7-9x8v-8gm4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 4.84.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/fleetdm/fleet/v4
- Affected
- <= 4.84.1
- Fixed in
- 4.84.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vxm7-9x8v-8gm4 lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <=4.84.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-46370: 0.37% estimated exploitation activity in the next 30 days; percentile 31.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability in Fleet's labels host-listing endpoint allowed authenticated users with the lowest-privilege Observer role to extract host enrollment secrets (nodekey, orbitnodekey) through a cursor-based binary search oracle. The endpoint accepted a user-supplied orderkey parameter that was not validated against a column allowlist, permitting sort order to be driven by sensitive columns in a joined table. Impact The GET /api/v1/fleet/labels/{id}/hosts endpoint constructs its query using a deprecated helper that did not restrict which columns could appear in the ORDER BY clause. An attacker with Global Observer or Team Observer credentials could supply a sensitive column name (for example, h.nodekey) as orderkey and combine it with the cursor-based after parameter to binary-search the values of those columns one character at a time. The targeted values never appeared in the response body, but the presence or absence of results revealed each character. The nodekey and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vxm7-9x8v-8gm4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46370 Advisory: Fleet has observer-level enrollment secret extraction via ORDER BY oracle on labels host-listing endpoint IDs: CVE-2026-46370, GHSA-vxm7-9x8v-8gm4 Record: https://patchnext.com/advisories/cve-2026-46370 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 4.84.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fleetdm/fleet/v4: affected <= 4.84.1; fixed in 4.84.2 ## Suggested inspection (read-only) - Go github.com/fleetdm/fleet/v4: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fleetdm/fleet/v4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vxm7-9x8v-8gm4 (GitHub-reviewed advisory GHSA-vxm7-9x8v-8gm4 lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <=4.84.1) Commands are suggestions: review each one before running it.
Loading voting…