compliance-trestle - jinja has an Arbitrary File Write via Path Traversal
CVE-2026-46345GHSA-4q5v-7g7x-j79w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (compliance-trestle 4.0.3, 3.12.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI compliance-trestle
- Affected
- >= 4.0.0, < 4.0.3<= 3.12.1
- Fixed in
- 3.12.2, 4.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4q5v-7g7x-j79w lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4q5v-7g7x-j79w lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <=3.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-46345: 0.20% estimated exploitation activity in the next 30 days; percentile 10.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Relevant Products/Components: trestle/core/commands/author/jinja.py trestle author jinja --- Detailed Description: The -o/--output argument in trestle author jinja allows writing files outside the intended workspace. The application does not properly validate: ../ ..\ absolute paths This allows arbitrary file write to attacker-controlled locations. Vulnerable code: An attacker can overwrite files such as: .github/workflows/.yml .git/hooks/ user writable config files This can lead to CI/CD compromise or local code execution. --- Steps To Reproduce: 1. Clone the repository: 2. Create template: 3. Run: 4. Observe: The file is written outside the repository workspace. --- Browsers Verified In: Not browser related. Tested on: Windows 11 Python 3.13 --- Supporting Material/References: Affected file: Successfully verified: directory traversal using ../ Windows traversal using ..\ arbitrary file write outside workspace --- Access Vector Required for Exploitation: Local --- Vulnerability…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4q5v-7g7x-j79w
- Revision 1 · created ·
Published from osv record GHSA-4q5v-7g7x-j79w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46345 Advisory: compliance-trestle - jinja has an Arbitrary File Write via Path Traversal IDs: CVE-2026-46345, GHSA-4q5v-7g7x-j79w Record: https://patchnext.com/advisories/cve-2026-46345 (revision 2, source checked 26 Oct 2026, 13:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: compliance-trestle 4.0.3, 3.12.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI compliance-trestle: affected >= 4.0.0, < 4.0.3; <= 3.12.1; fixed in 3.12.2, 4.0.3 ## Suggested inspection (read-only) - `python -m pip show compliance-trestle`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on compliance-trestle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4q5v-7g7x-j79w (OSV record GHSA-4q5v-7g7x-j79w lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <3.12.2 (fixed)) - Verified: https://github.com/advisories/GHSA-4q5v-7g7x-j79w (GitHub-reviewed advisory GHSA-4q5v-7g7x-j79w lists affected ranges: PyPI compliance-trestle >=4.0.0 =0 <=3.12.1) Commands are suggestions: review each one before running it.
Loading voting…