Apify Model Context Protocol (MCP) server: Domain Allowlist Bypass in fetch-apify-docs via String Prefix Matching
CVE-2026-46341GHSA-jwp7-wg77-3w9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@apify/actors-mcp-server 0.9.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.9.21
- Fixed in
- 0.9.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jwp7-wg77-3w9v lists affected ranges: npm @apify/actors-mcp-server >=0 <0.9.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwp7-wg77-3w9v lists affected ranges: npm @apify/actors-mcp-server >=0 <0.9.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-46341: 0.23% estimated exploitation activity in the next 30 days; percentile 14.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The fetch-apify-docs tool validates URLs against a domain allowlist using String.startsWith() instead of proper URL hostname comparison. This allows bypass via attacker-controlled subdomains (e.g., https://docs.apify.com.evil.com/), enabling the tool to fetch and return arbitrary web content to the LLM. Details Vulnerable component src/tools/common/fetchapifydocs.ts, line 51: src/const.ts, lines 167-170: How the bypass works String.startsWith('https://docs.apify.com') matches any string beginning with that prefix, including: - https://docs.apify.com.evil.com/payload - attacker-controlled subdomain - https://docs.apify.com@evil.com/payload - userinfo component in URL (browser behavior varies, but fetch() in Node.js may follow this) - https://docs.apify.com.evil.com:8080/path - custom port on attacker domain All of these pass the startsWith check because they begin with the exact string https://docs.apify.com. The fetched content is returned to the LLM After the allowlist check…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jwp7-wg77-3w9v
- Revision 1 · created ·
Published from osv record GHSA-jwp7-wg77-3w9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46341 Advisory: Apify Model Context Protocol (MCP) server: Domain Allowlist Bypass in fetch-apify-docs via String Prefix Matching IDs: CVE-2026-46341, GHSA-jwp7-wg77-3w9v Record: https://patchnext.com/advisories/cve-2026-46341 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @apify/actors-mcp-server 0.9.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @apify/actors-mcp-server: affected < 0.9.21; fixed in 0.9.21 ## Suggested inspection (read-only) - `npm ls @apify/actors-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @apify/actors-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jwp7-wg77-3w9v (OSV record GHSA-jwp7-wg77-3w9v lists affected ranges: npm @apify/actors-mcp-server >=0 <0.9.21 (fixed)) - Verified: https://github.com/advisories/GHSA-jwp7-wg77-3w9v (GitHub-reviewed advisory GHSA-jwp7-wg77-3w9v lists affected ranges: npm @apify/actors-mcp-server >=0 <0.9.21) Commands are suggestions: review each one before running it.
Loading voting…