9router: Unauthenticated Remote Code Execution via unprotected MCP custom plugin routes
CVE-2026-46339GHSA-fhh6-4qxv-rpqj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (9router 0.4.37), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm 9router
- Affected
- >= 0.4.30, < 0.4.37
- Fixed in
- 0.4.37
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fhh6-4qxv-rpqj lists affected ranges: npm 9router >=0.4.30 <0.4.37
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fhh6-4qxv-rpqj lists affected ranges: npm 9router >=0.4.30 <0.4.37 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-46339: 2.76% estimated exploitation activity in the next 30 days; percentile 86.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary 9router exposes two unauthenticated API endpoints that, when chained together, allow any network-adjacent attacker to execute arbitrary OS commands as the user running the 9router process — with zero prerequisites and no credentials required. The vulnerability exists because the Next.js middleware that enforces authentication (src/proxy.js) only guards 8 explicitly listed routes. The attack surface of /api/cli-tools/ and /api/mcp/ (40+ routes) receives no authentication whatsoever. --- Root Cause 1. Middleware Allowlist Is Too Narrow File: src/proxy.js Next.js middleware only runs on routes matching this list. Routes NOT listed — including /api/cli-tools/ and /api/mcp/ — bypass the dashboardGuard auth check entirely. 2. Unguarded Endpoint Accepts Arbitrary Command Registration File: src/app/api/cli-tools/cowork-settings/route.js, lines 292–319 The command and args fields from the attacker's JSON are stored verbatim into globalThis.9routerCustomPlugins — a process-global Map…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fhh6-4qxv-rpqj
- Revision 2 · amended ·
Amended from osv record GHSA-fhh6-4qxv-rpqj
- Revision 1 · created ·
Published from ghsa record GHSA-fhh6-4qxv-rpqj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-46339 Advisory: 9router: Unauthenticated Remote Code Execution via unprotected MCP custom plugin routes IDs: CVE-2026-46339, GHSA-fhh6-4qxv-rpqj Record: https://patchnext.com/advisories/cve-2026-46339 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: 9router 0.4.37. A vendor fix does not mean a deployment is fixed. ## Affected components - npm 9router: affected >= 0.4.30, < 0.4.37; fixed in 0.4.37 ## Suggested inspection (read-only) - `npm ls 9router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on 9router. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fhh6-4qxv-rpqj (GitHub-reviewed advisory GHSA-fhh6-4qxv-rpqj lists affected ranges: npm 9router >=0.4.30 <0.4.37) - Verified: https://osv.dev/vulnerability/GHSA-fhh6-4qxv-rpqj (OSV record GHSA-fhh6-4qxv-rpqj lists affected ranges: npm 9router >=0.4.30 <0.4.37 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…