Skip to content

← Actionable
High, CVSS 7.5amended

Diffusers: TOCTOU Trust Remote Code Bypass

CVE-2026-45804GHSA-7wx4-6vff-v64p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (diffusers 0.38.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-45804: 0.37% estimated exploitation activity in the next 30 days; percentile 30.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Background This vulnerability is found in the diffusers package - the transformers-equivalent library for diffusion models. It is found in the DiffusionPipeline.frompretrained flow, which is used to load a pipeline from the HuggingFace Hub. This function has a trustremotecode guard: if the repository’s modelindex.json references a custom pipeline class defined in a .py file in the repo, the load is blocked unless trustremotecode=True is explicitly passed: The vulnerability allows arbitrary code execution through the custom pipeline flow from a Hub repo, with no custompipeline or trustremotecode kwargs passed. The frompretrained call succeeds and returns a functional pipeline. --- Naive Flow DiffusionPipeline.frompretrained begins by popping all relevant arguments from kwargs into local variables, then calls DiffusionPipeline.download() to fetch the repo files: Inside download(), modelindex.json is fetched first as a standalone file via hfhubdownload: This config is used to detect…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7wx4-6vff-v64p

  2. Revision 1 · created ·

    Published from osv record GHSA-7wx4-6vff-v64p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45804

Advisory: Diffusers: TOCTOU Trust Remote Code Bypass
IDs: CVE-2026-45804, GHSA-7wx4-6vff-v64p
Record: https://patchnext.com/advisories/cve-2026-45804 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: diffusers 0.38.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI diffusers: affected < 0.38.0; fixed in 0.38.0

## Suggested inspection (read-only)
- `python -m pip show diffusers`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on diffusers.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7wx4-6vff-v64p (OSV record GHSA-7wx4-6vff-v64p lists affected ranges: PyPI diffusers >=0 <0.38.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7wx4-6vff-v64p (GitHub-reviewed advisory GHSA-7wx4-6vff-v64p lists affected ranges: PyPI diffusers >=0 <0.38.0)

Commands are suggestions: review each one before running it.

Loading voting…