Turbo: Unexpected local code execution during Yarn Berry detection
CVE-2026-45772GHSA-3qcw-2rhx-2726
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@turbo/workspaces 2.9.14; @turbo/codemod 2.9.14; turbo 2.9.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.3.4, < 2.9.14
- Fixed in
- 2.9.14
npm @turbo/codemod
- Affected
- >= 2.3.4, < 2.9.14
- Fixed in
- 2.9.14
npm turbo
- Affected
- >= 1.1.0, < 2.9.14
- Fixed in
- 2.9.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3qcw-2rhx-2726 lists affected ranges: npm turbo >=1.1.0 =2.3.4 =2.3.4 <2.9.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3qcw-2rhx-2726 lists affected ranges: npm turbo >=1.1.0 =2.3.4 =2.3.4 <2.9.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 0.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-45772: 0.39% estimated exploitation activity in the next 30 days; percentile 32.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Turborepo can be vulnerable to arbitrary code execution when run in untrusted repositories that contain malicious Yarn configuration. In affected versions, package manager detection executed yarn --version from the project directory, which could cause Yarn to load and execute a project-controlled yarnPath from .yarnrc.yml. An attacker who controls repository contents could cause code execution when a user or CI system runs affected turbo, @turbo/codemod, or @turbo/workspace conversion commands. Fix Turbo now avoids executing project-local Yarn during package manager detection. Yarn versions and paths are inferred from metadata such as package.json, parsing the value of yarnPath in .yarnrc.yml rather than executing it, and yarn.lock, and unrecognized Yarn lockfile formats are rejected instead of falling back to executing yarn. Workarounds If you cannot upgrade immediately, do not run Turborepo commands in untrusted repositories. Review or remove .yarnrc.yml files that define…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3qcw-2rhx-2726
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3qcw-2rhx-2726
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45772 Advisory: Turbo: Unexpected local code execution during Yarn Berry detection IDs: CVE-2026-45772, GHSA-3qcw-2rhx-2726 Record: https://patchnext.com/advisories/cve-2026-45772 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated (CVSS 0.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @turbo/workspaces 2.9.14; @turbo/codemod 2.9.14; turbo 2.9.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @turbo/workspaces: affected >= 2.3.4, < 2.9.14; fixed in 2.9.14 - npm @turbo/codemod: affected >= 2.3.4, < 2.9.14; fixed in 2.9.14 - npm turbo: affected >= 1.1.0, < 2.9.14; fixed in 2.9.14 ## Suggested inspection (read-only) - `npm ls @turbo/workspaces --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @turbo/codemod --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls turbo --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @turbo/workspaces, @turbo/codemod, turbo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3qcw-2rhx-2726 (OSV record GHSA-3qcw-2rhx-2726 lists affected ranges: npm turbo >=1.1.0 =2.3.4 =2.3.4 <2.9.14 (fixed)) - Verified: https://github.com/advisories/GHSA-3qcw-2rhx-2726 (GitHub-reviewed advisory GHSA-3qcw-2rhx-2726 lists affected ranges: npm turbo >=1.1.0 =2.3.4 =2.3.4 <2.9.14) Commands are suggestions: review each one before running it.
Loading voting…