Malicious code in guardrails-ai 0.10.1 (supply chain compromise)
CVE-2026-45758GHSA-xmpw-2vmm-p4p6
What to do
Vendor response not established. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI guardrails-ai
- Affected
- >= 0.10.1, <= 0.10.1
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xmpw-2vmm-p4p6 lists affected ranges: PyPI guardrails-ai >=0.10.1 <=0.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xmpw-2vmm-p4p6 lists affected ranges: PyPI guardrails-ai >=0.10.1 <=0.10.1
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-45758: 0.28% estimated exploitation activity in the next 30 days; percentile 20.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of guardrails-ai (0.10.1) to PyPI. Affected: any user who installed guardrails-ai==0.10.1 from PyPI on May 11, 2026. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, we have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through our systems. For the full timeline, technical details, and remediation steps we have taken, see SECURITYADVISORY.md. Patches No patched version above 0.10.1 is available yet. Downgrade to 0.10.0, which is unaffected. Workarounds 1. Pin to a safe version: guardrails-ai==0.10.0 2. While the PyPI quarantine is active, install from GitHub: pip install git+https://github.com/guardrails-ai/guardrails.git@v0.10.0 The…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-xmpw-2vmm-p4p6
- Revision 2 · amended ·
Amended from osv record GHSA-xmpw-2vmm-p4p6
- Revision 1 · created ·
Published from ghsa record GHSA-xmpw-2vmm-p4p6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45758 Advisory: Malicious code in guardrails-ai 0.10.1 (supply chain compromise) IDs: CVE-2026-45758, GHSA-xmpw-2vmm-p4p6 Record: https://patchnext.com/advisories/cve-2026-45758 (revision 3, source checked 26 Oct 2026, 13:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor response not established. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI guardrails-ai: affected >= 0.10.1, <= 0.10.1 ## Suggested inspection (read-only) - `python -m pip show guardrails-ai`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on guardrails-ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xmpw-2vmm-p4p6 (GitHub-reviewed advisory GHSA-xmpw-2vmm-p4p6 lists affected ranges: PyPI guardrails-ai >=0.10.1 <=0.10.1) - Verified: https://osv.dev/vulnerability/GHSA-xmpw-2vmm-p4p6 (OSV record GHSA-xmpw-2vmm-p4p6 lists affected ranges: PyPI guardrails-ai >=0.10.1 <=0.10.1) Commands are suggestions: review each one before running it.
Loading voting…