protobufjs: Denial of Service via unbounded recursive JSON descriptor expansion
CVE-2026-45740GHSA-jggg-4jg4-v7c6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs 8.2.0, 7.5.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm protobufjs
- Affected
- <= 7.5.7>= 8.0.0, < 8.2.0
- Fixed in
- 7.5.8, 8.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jggg-4jg4-v7c6 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jggg-4jg4-v7c6 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-45740: 0.26% estimated exploitation activity in the next 30 days; percentile 18.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary protobufjs could recurse without a depth limit while expanding nested JSON descriptors through Root.fromJSON() and Namespace.addJSON(). A crafted JSON descriptor with deeply nested namespace definitions could cause the JavaScript call stack to be exhausted during descriptor loading. Impact An attacker who can provide JSON descriptors loaded by an application may be able to crash the process or otherwise cause schema loading to fail with a stack overflow. This affects applications that load JSON descriptors from untrusted sources with affected versions. Preconditions - The application must load JSON descriptor data influenced by an attacker. - The crafted descriptor must contain deeply nested nested namespace objects. - The affected Root.fromJSON() / Namespace.addJSON() descriptor expansion path must process the crafted input. Workarounds Avoid loading untrusted protobuf JSON descriptors with affected versions. If immediate upgrade is not possible, reject excessively nested…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jggg-4jg4-v7c6
- Revision 1 · created ·
Published from osv record GHSA-jggg-4jg4-v7c6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45740 Advisory: protobufjs: Denial of Service via unbounded recursive JSON descriptor expansion IDs: CVE-2026-45740, GHSA-jggg-4jg4-v7c6 Record: https://patchnext.com/advisories/cve-2026-45740 (revision 2, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: protobufjs 8.2.0, 7.5.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm protobufjs: affected <= 7.5.7; >= 8.0.0, < 8.2.0; fixed in 7.5.8, 8.2.0 ## Suggested inspection (read-only) - `npm ls protobufjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on protobufjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jggg-4jg4-v7c6 (OSV record GHSA-jggg-4jg4-v7c6 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jggg-4jg4-v7c6 (GitHub-reviewed advisory GHSA-jggg-4jg4-v7c6 lists affected ranges: npm protobufjs >=0 =8.0.0 <8.2.0) Commands are suggestions: review each one before running it.
Loading voting…