Skip to content

← Actionable
Low, CVSS 3.1amended

Strawberry GraphQL: Default GraphiQL may expose HTTP headers in URLs

CVE-2026-45739GHSA-x97m-qp5c-w9xj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (strawberry-graphql 0.315.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2026-45739: 0.22% estimated exploitation activity in the next 30 days; percentile 12.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Strawberry's bundled GraphiQL template wrote values from the GraphiQL headers editor into the browser URL query string. If a user entered a sensitive header, such as Authorization: Bearer <token, the value could become visible in browser history, copied links, and server/proxy/CDN access logs after a page reload or shared request. Affected Versions - Affected: strawberry-graphql = 0.288.4, <= 0.315.3 - Patched: 0.315.4 The vulnerable behavior was introduced by the GraphiQL URL-sharing implementation in commit 9315ef80, first included in release 0.288.4. Impact Applications that expose Strawberry's default GraphiQL IDE may leak sensitive HTTP header values entered by users into the GraphiQL headers editor. The default IDE is enabled by graphqlide="graphiql" across Strawberry HTTP integrations unless disabled or replaced by the application. The exposure is limited to the browser-based IDE. GraphQL query execution is not affected, and this issue does not allow an attacker to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x97m-qp5c-w9xj

  2. Revision 1 · created ·

    Published from osv record GHSA-x97m-qp5c-w9xj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45739

Advisory: Strawberry GraphQL: Default GraphiQL may expose HTTP headers in URLs
IDs: CVE-2026-45739, GHSA-x97m-qp5c-w9xj
Record: https://patchnext.com/advisories/cve-2026-45739 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: strawberry-graphql 0.315.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI strawberry-graphql: affected >= 0.288.4, <= 0.315.3; fixed in 0.315.4

## Suggested inspection (read-only)
- `python -m pip show strawberry-graphql`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on strawberry-graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x97m-qp5c-w9xj (OSV record GHSA-x97m-qp5c-w9xj lists affected ranges: PyPI strawberry-graphql >=0.288.4 <0.315.4 (fixed))
- Verified: https://github.com/advisories/GHSA-x97m-qp5c-w9xj (GitHub-reviewed advisory GHSA-x97m-qp5c-w9xj lists affected ranges: PyPI strawberry-graphql >=0.288.4 <=0.315.3)

Commands are suggestions: review each one before running it.

Loading voting…