Skip to content

← Actionable
Medium, CVSS 6.5amended

Budibase: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API

CVE-2026-45719GHSA-363w-hvwh-w7m6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.38.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-45719: 0.26% estimated exploitation activity in the next 30 days; percentile 18.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security Advisory: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API Affected Software: Budibase Affected Component: packages/server/src/api/controllers/view/viewBuilder.ts, packages/server/src/api/routes/view.ts CWE: CWE-94 (Improper Control of Generation of Code) Discovery Date: 2026-03-24 --- Summary The V1 Views API (POST /api/views) accepts a calculation parameter from the request body that is interpolated directly into a CouchDB reduce function definition without validation. Although an internal SCHEMAMAP object defines the valid calculation types (sum, count, stats), no actual validation is performed against this map before the value is used in string interpolation. A user with Builder permissions can inject arbitrary JavaScript code that will be executed within the CouchDB JavaScript engine when the view is queried. --- Affected Component Route: POST /api/views (V1 legacy views endpoint) File: packages/server/src/api/routes/view.ts, line 45 Note:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-363w-hvwh-w7m6

  2. Revision 1 · created ·

    Published from osv record GHSA-363w-hvwh-w7m6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45719

Advisory: Budibase: CouchDB Reduce Injection via Unsanitized Calculation Parameter in V1 Views API
IDs: CVE-2026-45719, GHSA-363w-hvwh-w7m6
Record: https://patchnext.com/advisories/cve-2026-45719 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.38.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.38.1; fixed in 3.38.1

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-363w-hvwh-w7m6 (OSV record GHSA-363w-hvwh-w7m6 lists affected ranges: npm @budibase/server >=0 <3.38.1 (fixed))
- Verified: https://github.com/advisories/GHSA-363w-hvwh-w7m6 (GitHub-reviewed advisory GHSA-363w-hvwh-w7m6 lists affected ranges: npm @budibase/server >=0 <3.38.1)

Commands are suggestions: review each one before running it.

Loading voting…