Budibase: Row Action Trigger Bypasses View Row Filter Security Boundary Allowing Action on Out-of-Scope Rows
CVE-2026-45718GHSA-3263-v5v9-xq8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (budibase 3.38.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm budibase
- Affected
- < 3.38.1
- Fixed in
- 3.38.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3263-v5v9-xq8q lists affected ranges: npm budibase >=0 <3.38.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3263-v5v9-xq8q lists affected ranges: npm budibase >=0 <3.38.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-45718: 0.15% estimated exploitation activity in the next 30 days; percentile 3.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The row action trigger endpoint (POST /api/tables/:sourceId/actions/:actionId/trigger) fails to validate that the user-supplied rowId is within the scope of the view's row filters. A user with access to a filtered view can trigger row actions on any row in the underlying table, including rows explicitly excluded by the view's security filters. Details View filters in Budibase are treated as a security boundary. The search path (packages/server/src/sdk/workspace/rows/search.ts:93-94) explicitly enforces view query filters with the comment: "that could let users find rows they should not be allowed to access." However, the row action trigger path bypasses this enforcement entirely: 1. Route (packages/server/src/api/routes/rowAction.ts:55-59): Accepts a sourceId that can be a viewId. 2. Middleware (packages/server/src/middleware/triggerRowActionAuthorised.ts:24-55): Correctly validates that the user has READ permission on the view and that the row action is enabled for that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3263-v5v9-xq8q
- Revision 1 · created ·
Published from osv record GHSA-3263-v5v9-xq8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45718 Advisory: Budibase: Row Action Trigger Bypasses View Row Filter Security Boundary Allowing Action on Out-of-Scope Rows IDs: CVE-2026-45718, GHSA-3263-v5v9-xq8q Record: https://patchnext.com/advisories/cve-2026-45718 (revision 2, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: budibase 3.38.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm budibase: affected < 3.38.1; fixed in 3.38.1 ## Suggested inspection (read-only) - `npm ls budibase --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on budibase. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3263-v5v9-xq8q (OSV record GHSA-3263-v5v9-xq8q lists affected ranges: npm budibase >=0 <3.38.1 (fixed)) - Verified: https://github.com/advisories/GHSA-3263-v5v9-xq8q (GitHub-reviewed advisory GHSA-3263-v5v9-xq8q lists affected ranges: npm budibase >=0 <3.38.1) Commands are suggestions: review each one before running it.
Loading voting…