Skip to content

← Actionable
High, CVSS 7.7amended

Budibase: SSRF Bypass via HTTP Redirect in REST Datasource Integration

CVE-2026-45715GHSA-fgqv-jh4g-pvg2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@budibase/server 3.38.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2026-45715: 0.26% estimated exploitation activity in the next 30 days; percentile 17.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The REST datasource integration follows HTTP redirects without re-checking the IP blacklist, allowing an authenticated Builder to access internal services (cloud metadata, databases) by redirecting through an attacker-controlled server. The same vulnerability class was already patched in automation steps (fetchWithBlacklist in packages/server/src/automations/steps/utils.ts) but the REST integration was missed. Details Vulnerable file: packages/server/src/integrations/rest.ts, lines 754-778 The req() method checks the request URL against the IP blacklist at line 754, then calls fetch(url, input) at line 778. No redirect: "manual" option is set, so undici's fetch defaults to redirect: "follow", automatically following HTTP 301/302/307 redirects without re-validating the redirect target against the blacklist. The automation steps already implement the correct fix in packages/server/src/automations/steps/utils.ts (lines 100-136) via fetchWithBlacklist(), which sets redirect:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fgqv-jh4g-pvg2

  2. Revision 1 · created ·

    Published from osv record GHSA-fgqv-jh4g-pvg2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45715

Advisory: Budibase: SSRF Bypass via HTTP Redirect in REST Datasource Integration
IDs: CVE-2026-45715, GHSA-fgqv-jh4g-pvg2
Record: https://patchnext.com/advisories/cve-2026-45715 (revision 2, source checked 26 Oct 2026, 12:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @budibase/server 3.38.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @budibase/server: affected < 3.38.1; fixed in 3.38.1

## Suggested inspection (read-only)
- `npm ls @budibase/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @budibase/server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fgqv-jh4g-pvg2 (OSV record GHSA-fgqv-jh4g-pvg2 lists affected ranges: npm @budibase/server >=0 <3.38.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fgqv-jh4g-pvg2 (GitHub-reviewed advisory GHSA-fgqv-jh4g-pvg2 lists affected ranges: npm @budibase/server >=0 <3.38.1)

Commands are suggestions: review each one before running it.

Loading voting…