Pimcore has a CustomReports Share Bypass
CVE-2026-45704GHSA-jwcc-gv4m-93x6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 2026.1.2, 12.3.6, 11.5.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- >= 12.0.0-RC1, <= 12.3.5<= 11.5.16>= 2026.1.0, < 2026.1.2
- Fixed in
- 12.3.6, 2026.1.2, 11.5.17
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwcc-gv4m-93x6 lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 =2026.1.0 <2026.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-45704: 0.43% estimated exploitation activity in the next 30 days; percentile 37.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary CustomReports uses inconsistent authorization between the report listing endpoint and the report detail endpoint. - The listing flow filters reports based on report-sharing rules - The detail flow only checks generic reports or reportsconfig permissions As a result, a low-privileged backend user who was not granted access to a report can still read that report directly by name even though it does not appear in the user's visible report list. In the local Docker reproduction: - The report poc-secret-report was not visible to the low-privileged user in the report list - The same user was still able to retrieve the report configuration directly by name Root Cause The listing flow in getReportConfigAction() filters reports through loadForGivenUser(): - CustomReportController.php -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jwcc-gv4m-93x6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45704 Advisory: Pimcore has a CustomReports Share Bypass IDs: CVE-2026-45704, GHSA-jwcc-gv4m-93x6 Record: https://patchnext.com/advisories/cve-2026-45704 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 2026.1.2, 12.3.6, 11.5.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected >= 12.0.0-RC1, <= 12.3.5; <= 11.5.16; >= 2026.1.0, < 2026.1.2; fixed in 12.3.6, 2026.1.2, 11.5.17 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jwcc-gv4m-93x6 (GitHub-reviewed advisory GHSA-jwcc-gv4m-93x6 lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 =2026.1.0 <2026.1.2) Commands are suggestions: review each one before running it.
Loading voting…