Skip to content

← Actionable
Medium, CVSS 6.4

Pimcore has a WordExport Authorization Bypass for Unauthorized Document Export

CVE-2026-45703GHSA-332x-r494-54fq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 2026.1.3, 12.3.7, 11.5.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist pimcore/pimcore

    Affected
    >= 12.0.0-RC1, <= 12.3.6<= 11.5.16>= 2026.1.0, < 2026.1.3
    Fixed in
    2026.1.3, 12.3.7, 11.5.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:L
EPSS
  • CVE-2026-45703: 0.32% estimated exploitation activity in the next 30 days; percentile 24.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The WordExport export flow only checks whether the current backend user has the feature permission wordexport. It does not verify access rights on the target element itself. As a result, a low-privileged backend user can export document content even when the user does not have view permission on that document. In the local Docker reproduction, a low-privileged user successfully exported sensitive content from a page the user was not allowed to view: - POC-WORDEXPORT-TITLE - POC-WORDEXPORT-DESC Root Cause The controller only performs a feature-level permission check before starting the export flow: - TranslationController.php - TranslationController.php#L44) It then directly resolves the target element from attacker-controlled type/id input: - TranslationController.php -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-332x-r494-54fq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45703

Advisory: Pimcore has a WordExport Authorization Bypass for Unauthorized Document Export
IDs: CVE-2026-45703, GHSA-332x-r494-54fq
Record: https://patchnext.com/advisories/cve-2026-45703 (revision 1, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 2026.1.3, 12.3.7, 11.5.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pimcore/pimcore: affected >= 12.0.0-RC1, <= 12.3.6; <= 11.5.16; >= 2026.1.0, < 2026.1.3; fixed in 2026.1.3, 12.3.7, 11.5.17

## Suggested inspection (read-only)
- Packagist pimcore/pimcore: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pimcore/pimcore.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-332x-r494-54fq (GitHub-reviewed advisory GHSA-332x-r494-54fq lists affected ranges: Packagist pimcore/pimcore >=12.0.0-RC1 =0 =2026.1.0 <2026.1.3)

Commands are suggestions: review each one before running it.

Loading voting…