Formie: Pre-authenticated server-side template injection in Hidden fields
CVE-2026-45697GHSA-x7m9-mwc2-g6w2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (verbb/formie 3.1.24, 2.2.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist verbb/formie
- Affected
- >= 3.0.0-beta.1, < 3.1.24< 2.2.20
- Fixed in
- 3.1.24, 2.2.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7m9-mwc2-g6w2 lists affected ranges: Packagist verbb/formie >=3.0.0-beta.1 =0 <2.2.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-45697: 0.47% estimated exploitation activity in the next 30 days; percentile 41.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact - Unauthenticated users could submit crafted values into Hidden fields (with Default value → Custom) that were evaluated as Twig during submission handling, which could lead to serious compromise of the Craft site (depending on template/sandbox behavior). - Sites with public Formie forms that include at least one Hidden field with that configuration. - No CP login for the reported chain. Patches - 2.2.20, 3.1.24 Workarounds - Temporarily remove Hidden fields from public forms or switch Hidden default away from Custom where feasible - Otherwise, upgrade to patched versions
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x7m9-mwc2-g6w2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45697 Advisory: Formie: Pre-authenticated server-side template injection in Hidden fields IDs: CVE-2026-45697, GHSA-x7m9-mwc2-g6w2 Record: https://patchnext.com/advisories/cve-2026-45697 (revision 1, source checked 26 Oct 2026, 14:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: verbb/formie 3.1.24, 2.2.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist verbb/formie: affected >= 3.0.0-beta.1, < 3.1.24; < 2.2.20; fixed in 3.1.24, 2.2.20 ## Suggested inspection (read-only) - Packagist verbb/formie: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on verbb/formie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x7m9-mwc2-g6w2 (GitHub-reviewed advisory GHSA-x7m9-mwc2-g6w2 lists affected ranges: Packagist verbb/formie >=3.0.0-beta.1 =0 <2.2.20) Commands are suggestions: review each one before running it.
Loading voting…