Caddy: Remote Admin Authorization Bypass in /config API via Array Index Normalization
CVE-2026-45692GHSA-x5w9-xh9r-mvfc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/caddyserver/caddy/v2 2.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/caddyserver/caddy/v2
- Affected
- >= 2.4.0, < 2.11.3
- Fixed in
- 2.11.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x5w9-xh9r-mvfc lists affected ranges: Go github.com/caddyserver/caddy/v2 >=2.4.0 <2.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-45692: 0.24% estimated exploitation activity in the next 30 days; percentile 15.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This report is not about a normal textual prefix-expansion case. The issue here is that the authorization layer and the /config traversal layer do not agree on what object the path refers to. In this case, a path authorized for one config object is accepted, but then resolves to a different config object during traversal.
AI Disclosure The reporter used an LLM to help review the code, reason about the behavior, and help draft this report. The reporter manually reproduced and validated the issue locally, confirmed the relevant source paths, and captured the requests and responses below.
Summary A remote admin client certificate restricted to the following path: can still read and modify a different array element by requesting: /config/apps/http/servers/srv/routes/01 This happens because: - the authorization layer uses string prefix matching - the /config traversal layer parses array indices numerically using strconv.Atoi() So: - authorization sees /.../01 as matching /.../0 -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x5w9-xh9r-mvfc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45692 Advisory: Caddy: Remote Admin Authorization Bypass in `/config` API via Array Index Normalization IDs: CVE-2026-45692, GHSA-x5w9-xh9r-mvfc Record: https://patchnext.com/advisories/cve-2026-45692 (revision 1, source checked 26 Oct 2026, 15:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/caddyserver/caddy/v2 2.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/caddyserver/caddy/v2: affected >= 2.4.0, < 2.11.3; fixed in 2.11.3 ## Suggested inspection (read-only) - Go github.com/caddyserver/caddy/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/caddyserver/caddy/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x5w9-xh9r-mvfc (GitHub-reviewed advisory GHSA-x5w9-xh9r-mvfc lists affected ranges: Go github.com/caddyserver/caddy/v2 >=2.4.0 <2.11.3) Commands are suggestions: review each one before running it.
Loading voting…