Skip to content

← Actionable
High, CVSS 7.5

OpenTelemetry eBPF Instrumentation: Memcached payload length overflow can crash OBI

CVE-2026-45686GHSA-43g7-cwr8-q3jh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.opentelemetry.io/obi 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-45686: 0.35% estimated exploitation activity in the next 30 days; percentile 29.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A remotely reachable integer overflow in OBI's memcached text protocol parser can crash the OBI process and cause denial of service. When parsing memcached storage commands such as set, add, replace, append, prepend, or cas, OBI accepts extremely large <bytes values and adds the payload delimiter length without checking for overflow. A crafted request with <bytes set to math.MaxInt or math.MaxInt-1 causes the computed payload length to wrap negative and triggers a runtime panic in LargeBufferReader.Peek. Details The issue is in the memcached request parser at pkg/ebpf/common/memcacheddetecttransform.go. memcachedCommandBytesField parses the storage command <bytes field with strconv.Atoi and only rejects negative values: Because there is no upper bound check, values up to math.MaxInt are accepted. memcachedConsumeStoragePayload then computes the payload length by adding the trailing \r\n delimiter length: If bytesField is math.MaxInt or math.MaxInt-1, this addition overflows…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-43g7-cwr8-q3jh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45686

Advisory: OpenTelemetry eBPF Instrumentation: Memcached payload length overflow can crash OBI
IDs: CVE-2026-45686, GHSA-43g7-cwr8-q3jh
Record: https://patchnext.com/advisories/cve-2026-45686 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.opentelemetry.io/obi 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.opentelemetry.io/obi: affected >= 0.7.0, < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- Go go.opentelemetry.io/obi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.opentelemetry.io/obi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-43g7-cwr8-q3jh (GitHub-reviewed advisory GHSA-43g7-cwr8-q3jh lists affected ranges: Go go.opentelemetry.io/obi >=0.7.0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…