OpenTelemetry eBPF Instrumentation: MongoDB parser panics on malformed wire messages
CVE-2026-45685GHSA-j8p6-96vp-f3r9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.opentelemetry.io/obi 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.9.0
- Fixed in
- 0.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j8p6-96vp-f3r9 lists affected ranges: Go go.opentelemetry.io/obi >=0 <0.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-45685: 0.46% estimated exploitation activity in the next 30 days; percentile 40.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Malformed MongoDB wire messages can trigger uncaught panics in the MongoDB TCP parser, allowing a remote unauthenticated attacker to crash the telemetry agent and cause a denial of service. The parser operates on raw attacker-controlled network payloads before the input is fully validated, so a single crafted message can terminate telemetry collection for the affected process or node. Details MongoDB parsing support was introduced by commit 2070f568a (Add Initial support for mongodb), so the explicit released version minimum affected is v0.1.0. There are two related panic conditions in released go.opentelemetry.io/obi versions: - In v0.1.0 through v0.3.0, parseOpMessage reads OPMSG flag bits from buf[msgHeaderSize:msgHeaderSize+int32Size] without first ensuring the buffer is at least msgHeaderSize + int32Size bytes long. A truncated OPMSG packet can therefore trigger a slice-bounds panic before the parser returns an error. - In v0.1.0 through v0.3.0, parseSections consumes…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j8p6-96vp-f3r9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45685 Advisory: OpenTelemetry eBPF Instrumentation: MongoDB parser panics on malformed wire messages IDs: CVE-2026-45685, GHSA-j8p6-96vp-f3r9 Record: https://patchnext.com/advisories/cve-2026-45685 (revision 1, source checked 26 Oct 2026, 15:23 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: go.opentelemetry.io/obi 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go go.opentelemetry.io/obi: affected < 0.9.0; fixed in 0.9.0 ## Suggested inspection (read-only) - Go go.opentelemetry.io/obi: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on go.opentelemetry.io/obi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j8p6-96vp-f3r9 (GitHub-reviewed advisory GHSA-j8p6-96vp-f3r9 lists affected ranges: Go go.opentelemetry.io/obi >=0 <0.9.0) Commands are suggestions: review each one before running it.
Loading voting…