Skip to content

← Actionable
High, CVSS 7.5

OpenTelemetry eBPF Instrumentation: Postgres BIND parsing can panic on malformed payloads

CVE-2026-45678GHSA-pgvv-q3wf-mm9m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.opentelemetry.io/obi 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-45678: 0.34% estimated exploitation activity in the next 30 days; percentile 27.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Postgres protocol parser assumes BIND message payloads contain a valid NUL-terminated portal name. A crafted empty or unterminated payload can make OBI slice beyond the end of the captured buffer and panic. Details The vulnerable logic is in pkg/ebpf/common/sqldetectpostgres.go. In the BIND case, OBI converts the full payload to a string with unix.ByteSliceToString(msg.data), computes portalLen := len(portal) + 1, and then slices msg.data[portalLen:] to derive the statement name. There is no check that msg.data actually contains a NUL terminator or even enough bytes for portalLen. With an empty payload or a truncated message, portalLen can exceed the slice length and trigger a runtime panic. PoC Local testing with a minimal reproducer showed the expected slice bounds out of range crash for an empty BIND payload. Use a vulnerable build: Start a local Postgres instance and OBI: Send a malformed BIND frame with an empty payload: Run it: On a vulnerable build, the Postgres…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pgvv-q3wf-mm9m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45678

Advisory: OpenTelemetry eBPF Instrumentation: Postgres BIND parsing can panic on malformed payloads
IDs: CVE-2026-45678, GHSA-pgvv-q3wf-mm9m
Record: https://patchnext.com/advisories/cve-2026-45678 (revision 1, source checked 26 Oct 2026, 15:23 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.opentelemetry.io/obi 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.opentelemetry.io/obi: affected < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- Go go.opentelemetry.io/obi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.opentelemetry.io/obi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pgvv-q3wf-mm9m (GitHub-reviewed advisory GHSA-pgvv-q3wf-mm9m lists affected ranges: Go go.opentelemetry.io/obi >=0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…