Skip to content

← Actionable
High, CVSS 8.1amended

Open WebUI: LDAP and OAuth First-User Race Condition Allows Multiple Admin Accounts

CVE-2026-45675GHSA-h3ww-q6xx-w7x3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-45675: 0.35% estimated exploitation activity in the next 30 days; percentile 29.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The LDAP and OAuth authentication flows use a TOCTOU (Time-of-Check-Time-of-Use) pattern for first-user admin role assignment. The regular signup handler (signuphandler in auths.py, line 663) was explicitly patched to prevent this race with the comment "Insert with default role first to avoid TOCTOU race", but the LDAP and OAuth code paths were never updated with the same fix. Vulnerable Code LDAP (auths.py, lines 479-490) OAuth (oauth.py, lines 1103-1112, 1566-1574) Both paths determine the role BEFORE inserting the user, creating a race window where multiple concurrent requests on a fresh instance can all observe an empty database and all receive the admin role. Comparison with Patched Signup The signuphandler (auths.py, line 663) was explicitly fixed: The LDAP and OAuth paths did NOT receive this fix. Exploitation 1. Deploy Open WebUI with LDAP or OAuth enabled on a fresh instance (no existing users) 2. Send multiple concurrent authentication requests from different users…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h3ww-q6xx-w7x3

  2. Revision 1 · created ·

    Published from osv record GHSA-h3ww-q6xx-w7x3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45675

Advisory: Open WebUI: LDAP and OAuth First-User Race Condition Allows Multiple Admin Accounts
IDs: CVE-2026-45675, GHSA-h3ww-q6xx-w7x3
Record: https://patchnext.com/advisories/cve-2026-45675 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h3ww-q6xx-w7x3 (OSV record GHSA-h3ww-q6xx-w7x3 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-h3ww-q6xx-w7x3 (GitHub-reviewed advisory GHSA-h3ww-q6xx-w7x3 lists affected ranges: PyPI open-webui >=0 <=0.8.12)

Commands are suggestions: review each one before running it.

Loading voting…