Skip to content

← Actionable
High, CVSS 8.0amended

Open WebUI: shared-chat branch ignores access_type, allowing unauthorized file deletion

CVE-2026-45671GHSA-26g9-27vm-x3q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-45671: 0.27% estimated exploitation activity in the next 30 days; percentile 19.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Any authenticated user can permanently delete files owned by other users via DELETE /api/v1/files/{id} when the target file is referenced in any shared chat. The hasaccesstofile() authorization gate unconditionally grants access through its shared-chat branch. It checks neither the requesting user's identity nor the type of operation being performed. File UUIDs (which would otherwise be impractical to guess) are disclosed to any user with read access to a knowledge base via GET /api/v1/knowledge/{id}/files. Details The root cause is in hasaccesstofile() in backend/openwebui/routers/files.py. When a user calls DELETE /api/v1/files/{fileid}, the endpoint delegates authorization to hasaccesstofile(fileid, accesstype="write", user=requestinguser). Inside that function, one branch checks whether the file is referenced in any shared chat: This branch has two missing checks: 1. No user check: It asks "does any shared chat anywhere reference this file?", not "does the requesting user…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-26g9-27vm-x3q8

  2. Revision 1 · created ·

    Published from osv record GHSA-26g9-27vm-x3q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45671

Advisory: Open WebUI: shared-chat branch ignores access_type, allowing unauthorized file deletion
IDs: CVE-2026-45671, GHSA-26g9-27vm-x3q8
Record: https://patchnext.com/advisories/cve-2026-45671 (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI open-webui: affected <= 0.8.12; fixed in 0.9.0

## Suggested inspection (read-only)
- `python -m pip show open-webui`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-26g9-27vm-x3q8 (OSV record GHSA-26g9-27vm-x3q8 lists affected ranges: PyPI open-webui >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-26g9-27vm-x3q8 (GitHub-reviewed advisory GHSA-26g9-27vm-x3q8 lists affected ranges: PyPI open-webui >=0 <=0.8.12)

Commands are suggestions: review each one before running it.

Loading voting…