Nuxt: Dev server exposes built source over LAN to malicious sites (incomplete fix for GHSA-4gf7-ff8x-hq99)
CVE-2026-45670GHSA-6m52-m754-pw2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nuxt/rspack-builder 4.4.6, 3.21.6; @nuxt/webpack-builder 4.4.6, 3.21.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.15.4, <= 3.21.5>= 4.0.0-alpha.1, <= 4.4.5
- Fixed in
- 3.21.6, 4.4.6
- Affected
- >= 3.15.4, <= 3.21.5>= 4.0.0-alpha.1, <= 4.4.5
- Fixed in
- 3.21.6, 4.4.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6m52-m754-pw2g lists affected ranges: npm @nuxt/rspack-builder >=3.15.4 =4.0.0-alpha.1 =3.15.4 =4.0.0-alpha.1 <4.4.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m52-m754-pw2g lists affected ranges: npm @nuxt/rspack-builder >=3.15.4 =4.0.0-alpha.1 =3.15.4 =4.0.0-alpha.1 <=4.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.9 · CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-45670: 0.21% estimated exploitation activity in the next 30 days; percentile 10.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary This is an incomplete fix for GHSA-4gf7-ff8x-hq99. Source code may be stolen during dev when using the webpack / rspack builder if the dev server is bound to a non-loopback address (e.g. nuxt dev --host) and the developer opens a malicious site on the same network. Details The fix for GHSA-4gf7-ff8x-hq99 relied on Sec-Fetch-Mode and Sec-Fetch-Site headers. Because these headers are sent by the browsers only for potentially trustworthy origins, the check is able to bypass for non-potentially trustworthy origins. Since the attack requires the website to be accessible via a non-potentially trustworthy origin, only apps that are using --host is affected. PoC 1. Create a nuxt project with webpack / rspack builder. 1. Run npm run dev 1. Open http://localhost:3000 1. Run the script below in a web site that has a different origin. 1. You can see the source code output in the document and the devtools console. (This script is the similar with GHSA-4gf7-ff8x-hq99 except for the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6m52-m754-pw2g
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6m52-m754-pw2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-45670 Advisory: Nuxt: Dev server exposes built source over LAN to malicious sites (incomplete fix for GHSA-4gf7-ff8x-hq99) IDs: CVE-2026-45670, GHSA-6m52-m754-pw2g Record: https://patchnext.com/advisories/cve-2026-45670 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nuxt/rspack-builder 4.4.6, 3.21.6; @nuxt/webpack-builder 4.4.6, 3.21.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nuxt/rspack-builder: affected >= 3.15.4, <= 3.21.5; >= 4.0.0-alpha.1, <= 4.4.5; fixed in 3.21.6, 4.4.6 - npm @nuxt/webpack-builder: affected >= 3.15.4, <= 3.21.5; >= 4.0.0-alpha.1, <= 4.4.5; fixed in 3.21.6, 4.4.6 ## Suggested inspection (read-only) - `npm ls @nuxt/rspack-builder --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @nuxt/webpack-builder --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nuxt/rspack-builder, @nuxt/webpack-builder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6m52-m754-pw2g (OSV record GHSA-6m52-m754-pw2g lists affected ranges: npm @nuxt/rspack-builder >=3.15.4 =4.0.0-alpha.1 =3.15.4 =4.0.0-alpha.1 <4.4.6 (fixed)) - Verified: https://github.com/advisories/GHSA-6m52-m754-pw2g (GitHub-reviewed advisory GHSA-6m52-m754-pw2g lists affected ranges: npm @nuxt/rspack-builder >=3.15.4 =4.0.0-alpha.1 =3.15.4 =4.0.0-alpha.1 <=4.4.5) Commands are suggestions: review each one before running it.
Loading voting…