Skip to content

← Actionable
High, CVSS 8.1amended

Open WebUI has Stored XSS in Banner Component via Improper Sanitization Order

CVE-2026-45665GHSA-cqp4-qqvg-3787

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (open-webui 0.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-45665: 0.34% estimated exploitation activity in the next 30 days; percentile 26.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Stored Cross-Site Scripting (XSS) vulnerability exists in the Banner component due to an improper sanitization order (specifically, DOMPurify is executed before the marked library). This vulnerability allows a compromised or malicious administrator to plant a malicious payload in the global banner. Crucially, this vector enables Privilege Escalation, as the malicious banner is rendered for all users, including the Super Admin (Primary Admin). Consequently, the payload successfully bypasses the existing security mechanism. An attacker can leverage this to steal the Super Admin's session token Details Root Cause: The code attempts to sanitize the input using DOMPurify.sanitize() before parsing it with marked.parse(). DOMPurify cleans the raw input. Since Link)) is valid text (not HTML), it passes through DOMPurify unchanged. marked handles the text and converts it into a clickable HTML link: <a href="javascript:alert(javascript:alert(localStorage.token))"Link</a. This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cqp4-qqvg-3787

  2. Revision 1 · created ·

    Published from osv record GHSA-cqp4-qqvg-3787

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45665

Advisory: Open WebUI has Stored XSS in Banner Component via Improper Sanitization Order
IDs: CVE-2026-45665, GHSA-cqp4-qqvg-3787
Record: https://patchnext.com/advisories/cve-2026-45665 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: open-webui 0.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm open-webui: affected <= 0.7.2; fixed in 0.8.0

## Suggested inspection (read-only)
- `npm ls open-webui --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on open-webui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cqp4-qqvg-3787 (OSV record GHSA-cqp4-qqvg-3787 lists affected ranges: npm open-webui >=0 <0.8.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cqp4-qqvg-3787 (GitHub-reviewed advisory GHSA-cqp4-qqvg-3787 lists affected ranges: npm open-webui >=0 <=0.7.2)

Commands are suggestions: review each one before running it.

Loading voting…