Skip to content

← Actionable
Medium, CVSS 5.4

Statamic CMS: Server-Side Request Forgery via Glide

CVE-2026-45660GHSA-pf9c-ch8r-2958

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.18.1, 5.73.22), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist statamic/cms

    Affected
    < 5.73.22>= 6.0.0-alpha.1, < 6.18.1
    Fixed in
    5.73.22, 6.18.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-45660: 0.15% estimated exploitation activity in the next 30 days; percentile 4.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. Patches This has been fixed in 5.73.22 and 6.18.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pf9c-ch8r-2958

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-45660

Advisory: Statamic CMS: Server-Side Request Forgery via Glide
IDs: CVE-2026-45660, GHSA-pf9c-ch8r-2958
Record: https://patchnext.com/advisories/cve-2026-45660 (revision 1, source checked 26 Oct 2026, 14:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.18.1, 5.73.22. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist statamic/cms: affected < 5.73.22; >= 6.0.0-alpha.1, < 6.18.1; fixed in 5.73.22, 6.18.1

## Suggested inspection (read-only)
- Packagist statamic/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on statamic/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pf9c-ch8r-2958 (GitHub-reviewed advisory GHSA-pf9c-ch8r-2958 lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.18.1)

Commands are suggestions: review each one before running it.

Loading voting…